summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-07-27 11:05:09 +0200
committerAndreas Enge <andreas@enge.fr>2023-08-17 16:19:05 +0200
commit0421160f4a350de72422f4a51d7fd101b3764376 (patch)
treebd65c2f4a1cc6a9b9c2246aa02227be9350813a7 /gnu/packages/patches
parent314e984d6c3836a28528f057d8b2418e1cfdbd5b (diff)
gnu: texlive: Reinstate the monolithic texlive package.
This goes back essentially to commit ad457d01147b8d6fcb4ee64b2dc2d699caa1d1ee and defines the monolithic texlive packages independently of the modular ones. It also downgrades their version to 2021. Not using dashes in the names of texlivebin and texlivetexmf prevents the profile hook for font mapping from being run during the command "guix shell -D texlive". * gnu/packages/tex.scm (texlive-bin-full): Remove variable. (biber): Remove variable deprecation. (texlive-texm, texlive): Move variables from here... * gnu/packages/texlive.scm (texlivetexm, texlive): ...to this new file. (%texlive-date, %texlive-version, %texlive-tag, %texlive-revision, texlive-extra-src, texlive-texmf-src, texlivebin): New variables. (biber): Add variable again. * gnu/packages/patches/biber-adapt-perl-5.36.patch: Add file again. * gnu/local.mk (GNU_SYSTEM_MODULES, dist_patch_DATA): Register files.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/biber-adapt-perl-5.36.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/biber-adapt-perl-5.36.patch b/gnu/packages/patches/biber-adapt-perl-5.36.patch
new file mode 100644
index 0000000000..895813c1f2
--- /dev/null
+++ b/gnu/packages/patches/biber-adapt-perl-5.36.patch
@@ -0,0 +1,40 @@
+From d9e961710074d266ad6bdf395c98868d91952088 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Petr=20P=C3=ADsa=C5=99?= <ppisar@redhat.com>
+Date: Wed, 25 May 2022 12:41:59 +0200
+Subject: [PATCH] Adapt to Perl 5.36
+
+A developmental release of Perl 5.36.0 fails to run tests with:
+
+ $ perl -Ilib t/basic-misc.t
+ 1..72
+ Can't modify undef operator in scalar assignment at lib/Biber/Section.pm line 433, near "undef;"
+ Compilation failed in require at lib/Biber.pm line 24.
+ BEGIN failed--compilation aborted at lib/Biber.pm line 24.
+ Compilation failed in require at t/basic-misc.t line 11.
+ BEGIN failed--compilation aborted at t/basic-misc.t line 11.
+ # Looks like your test exited with 255 before it could output anything.
+
+This is because of a missing semicolon between commands in
+del_everykeys(). The new perl is more strict and raises a compile-time
+error:
+
+ $ perl -e '$a = undef $b = undef;'
+ Can't modify undef operator in scalar assignment at -e line 1, near "undef;"
+ Execution of -e aborted due to compilation errors.
+---
+ lib/Biber/Section.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/Biber/Section.pm b/lib/Biber/Section.pm
+index 03ed69a51..a78942f57 100644
+--- a/lib/Biber/Section.pm
++++ b/lib/Biber/Section.pm
+@@ -429,7 +429,7 @@ sub add_everykey {
+
+ sub del_everykeys {
+ my $self = shift;
+- $self->{everykey} = undef
++ $self->{everykey} = undef;
+ $self->{everykey_lc} = undef;
+ return;
+ }