summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-08-07 22:41:18 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-08-08 18:24:46 +0300
commitc791769511e258167cd0e7312f44ee5cb3e372ad (patch)
tree10fd7938195eed91c536ae66f502433e88afd175 /gnu/packages/patches
parent1ff4fef763f1bbbffc7f996fce15640aa79b445b (diff)
gnu: bash-completion: Update to 2.11.
* gnu/packages/bash.scm (bash-completion): Update to 2.11. [arguments]: Disable tests. * gnu/packages/patches/bash-completion-directories.patch: Update to changes in upstream code.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/bash-completion-directories.patch7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/patches/bash-completion-directories.patch b/gnu/packages/patches/bash-completion-directories.patch
index 021e34653b..798f51154c 100644
--- a/gnu/packages/patches/bash-completion-directories.patch
+++ b/gnu/packages/patches/bash-completion-directories.patch
@@ -10,11 +10,11 @@ This is what this patch does.
--- a/bash_completion
+++ b/bash_completion
-@@ -2016,7 +2016,13 @@ complete -F _minimal ''
+@@ -2173,7 +2173,13 @@ complete -F _minimal ''
__load_completion()
{
-- local -a dirs=( ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions )
+- local -a dirs=(${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions)
+ local -a dirs=(
+ ${BASH_COMPLETION_USER_DIR:-${XDG_DATA_HOME:-$HOME/.local/share}/bash-completion}/completions
+ "$HOME/.guix-profile/share/bash-completion/completions/$base"
@@ -22,6 +22,7 @@ This is what this patch does.
+ "/run/current-system/profile/share/bash-completion/completions/$base"
+ "/run/current-system/profile/etc/bash_completion.d/$base" )
+
- local OIFS=$IFS IFS=: dir cmd="${1##*/}" compfile
+ local ifs=$IFS IFS=: dir cmd="${1##*/}" compfile
+ [[ -n $cmd ]] || return 1
for dir in ${XDG_DATA_DIRS:-/usr/local/share:/usr/share}; do
dirs+=( $dir/bash-completion/completions )