summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-01-10 22:57:43 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-01-10 22:57:43 +0100
commitf122f2bead538617d3bd43a05fa6f2def5e03c05 (patch)
tree78022d1600b93d2bb2d5785b5bcf56d64ea4f839 /gnu/packages/patches
parent749c3e016a4297d2794cbebac0e07297d19b4ffd (diff)
gnu: sbcl: Fix riscv build.
* gnu/packages/patches/sbcl-fix-riscv-build.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. * gnu/packages/lisp.scm (sbcl)[source]: Use it. Change-Id: I63f1b9a7a7b6f3a1961d0a0cb31189b74a60abc3
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/sbcl-fix-riscv-build.patch19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/patches/sbcl-fix-riscv-build.patch b/gnu/packages/patches/sbcl-fix-riscv-build.patch
new file mode 100644
index 0000000000..3e01ee6579
--- /dev/null
+++ b/gnu/packages/patches/sbcl-fix-riscv-build.patch
@@ -0,0 +1,19 @@
+commit b286d92af7468164c155c70d38213211b296fdfe
+Author: Douglas Katzman <dougk@google.com>
+Date: Wed Jan 10 11:46:55 2024 -0500
+
+ Fix riscv build
+
+diff --git a/src/compiler/riscv/float.lisp b/src/compiler/riscv/float.lisp
+index ce46d24ac..a16380293 100644
+--- a/src/compiler/riscv/float.lisp
++++ b/src/compiler/riscv/float.lisp
+@@ -578,7 +578,7 @@
+ (:results (res :scs (double-reg)))
+ (:arg-types signed-num)
+ (:result-types double-float)
+- (:translate make-double-float)
++ (:translate %make-double-float)
+ (:policy :fast-safe)
+ (:generator 2
+ (inst fmvx-> :double res bits)))