summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2022-08-19 21:06:50 -0700
committerVagrant Cascadian <vagrant@debian.org>2022-08-19 21:17:12 -0700
commitf31e55d0819064557b9a2af687f05b131f5c4f26 (patch)
tree833f3ea0f6d985a590f02bec7428dded08812603 /gnu/packages/patches
parentd2b85f8906489fb95d8be41d6ba9fd520a5967d0 (diff)
gnu: perl-class-methodmaker: Build reproducibly.
* gnu/packages/patches/perl-class-methodmaker-reproducible.patch: New file. * gnu/local.mk (dist_patch_DATA): Add patch. * gnu/packages/perl.scm (perl-class-methodmaker)[source]: Use patch.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/perl-class-methodmaker-reproducible.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/patches/perl-class-methodmaker-reproducible.patch b/gnu/packages/patches/perl-class-methodmaker-reproducible.patch
new file mode 100644
index 0000000000..29a71babd1
--- /dev/null
+++ b/gnu/packages/patches/perl-class-methodmaker-reproducible.patch
@@ -0,0 +1,21 @@
+Description: make build reproducible by sorting hash keys
+ cf. https://reproducible.debian.net/dbd/unstable/amd64/libclass-methodmaker-perl_2.21-1.debbindiff.html
+Origin: vendor
+Bug-Debian: https://bugs.debian.org/778979
+Author: Chris Lamb <lamby@debian.org>
+Reviewed-by: gregor herrmann <gregoa@debian.org>
+Last-Update: 2015-05-02
+Forwarded: https://rt.cpan.org/Ticket/Display.html?id=104163
+Bug: https://rt.cpan.org/Ticket/Display.html?id=104163
+
+--- a/lib/Class/MethodMaker/OptExt.pm
++++ b/lib/Class/MethodMaker/OptExt.pm
+@@ -357,7 +357,7 @@
+
+ # -------------------------------------
+
+-sub option_names { grep $_ ne 'DEFAULT', keys %{OPTEXT()} }
++sub option_names { grep $_ ne 'DEFAULT', sort keys %{OPTEXT()} }
+
+ sub optcode {
+ my $class = shift;