summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-06-04 13:14:12 +0200
committerLudovic Courtès <ludo@gnu.org>2018-06-04 14:03:54 +0200
commit7394e264fced0d17dcbe98881624be8fa83165e3 (patch)
tree54606cdd67c6c224b3d778151f22adab330955b8 /gnu/packages/patches
parent831f07a009e2a4d84d257ff6e07341971b0fb6e8 (diff)
gnu: perf: Work around GCC bug.
Works around <https://bugs.gnu.org/31708>. * gnu/packages/patches/perf-gcc-ice.patch: New patch. * gnu/packages/linux.scm (perf)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/perf-gcc-ice.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/patches/perf-gcc-ice.patch b/gnu/packages/patches/perf-gcc-ice.patch
new file mode 100644
index 0000000000..58ab5359c2
--- /dev/null
+++ b/gnu/packages/patches/perf-gcc-ice.patch
@@ -0,0 +1,13 @@
+Work around this GCC ICE: <https://bugs.gnu.org/31708>.
+
+--- linux-4.16.13/tools/perf/util/header.c 2018-06-04 11:30:39.368146035 +0200
++++ linux-4.16.13/tools/perf/util/header.c 2018-06-04 11:34:04.667212378 +0200
+@@ -135,7 +135,7 @@ int do_write(struct feat_fd *ff, const v
+ int write_padded(struct feat_fd *ff, const void *bf,
+ size_t count, size_t count_aligned)
+ {
+- static const char zero_buf[NAME_ALIGN];
++ static const char zero_buf[NAME_ALIGN] = { 0 };
+ int err = do_write(ff, bf, count);
+
+ if (!err)