summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-05-29 15:41:06 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-05-29 15:41:06 +0200
commitb347317ae67c80d9ff3baca42aaab45002fc73e6 (patch)
tree0c6e064d340762f0848d0bb70b8b9c8fc16a5247 /gnu/packages/patches
parent82b695b834f88c5561de40e68f3fe7aa24d3b796 (diff)
parent6cedd611774f91056c70d8d3a175d514b9b9fc76 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-fix-scheme-indent-function.patch14
1 files changed, 7 insertions, 7 deletions
diff --git a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
index c5a426802c..4b7904ea3b 100644
--- a/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
+++ b/gnu/packages/patches/emacs-fix-scheme-indent-function.patch
@@ -14,16 +14,16 @@ The fix is made by Mark H Weaver <mhw@netris.org>:
--- a/lisp/progmodes/scheme.el
+++ b/lisp/progmodes/scheme.el
-@@ -482,6 +482,12 @@
- (> (length function) 3)
- (string-match "\\`def" function)))
- (lisp-indent-defform state indent-point))
+@@ -494,6 +494,12 @@ indentation."
+ (> (length function) 3)
+ (string-match "\\`def" function)))
+ (lisp-indent-defform state indent-point))
+ ((and (null method)
+ (> (length function) 1)
+ ;; The '#' in '#:' seems to get lost, not sure why
+ (string-match "\\`:" function))
+ (let ((lisp-body-indent 1))
+ (lisp-indent-defform state indent-point)))
- ((integerp method)
- (lisp-indent-specform method state
- indent-point normal-indent))
+ ((integerp method)
+ (lisp-indent-specform method state
+ indent-point normal-indent))