summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-09-14 09:21:32 +0300
committerAndrew Tropin <andrew@trop.in>2022-09-14 18:25:12 +0300
commit0336372296e676f97799d6a3a1e9cf209f14c6bc (patch)
tree3a66603e8b1041cb2e7732a72927fa8c47d6a997 /gnu/packages/patches
parent6cdde65bb53b439f25f007df238f549ba2debc72 (diff)
gnu: emacs-kv: Fix build.
Build fails with emacs-next cause of copypasted test defined two times. * gnu/packages/patches/emacs-kv-fix-tests.patch: New file. * gnu/packages/emacs-xyz.scm (emacs-kv): Use it here. * gnu/local.mk (dist_patch_DATA): Register it here.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-kv-fix-tests.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-kv-fix-tests.patch b/gnu/packages/patches/emacs-kv-fix-tests.patch
new file mode 100644
index 0000000000..35a6bf004c
--- /dev/null
+++ b/gnu/packages/patches/emacs-kv-fix-tests.patch
@@ -0,0 +1,30 @@
+From 4702849bfe7462fb6c6303786dac1b670c8f0f8f Mon Sep 17 00:00:00 2001
+From: Andrew Tropin <andrew@trop.in>
+Date: Wed, 14 Sep 2022 09:17:31 +0300
+Subject: [PATCH] remove copypasted kvaq test
+
+---
+ kv-tests.el | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/kv-tests.el b/kv-tests.el
+index 1713e5e..abd6a24 100644
+--- a/kv-tests.el
++++ b/kv-tests.el
+@@ -105,13 +105,6 @@
+ (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+ (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+
+-(ert-deftest kvaq ()
+- "Test the simple assq."
+- (should (equal :b (kvaq :a '((:a . :b)("a" . "b")))))
+- (should (equal 2 (kvaq 1 '((1 . 2)("a" . "b")))))
+- (should-not (equal "b" (kvaq "a" '((:a . :b)("a" . "b")))))
+- (should-not (kvaq "b" '((:a . :b)("a" . "b")))))
+-
+ (ert-deftest kvaqc ()
+ "Test the simple assq."
+ (should (equal :b (kvaqc :a '((:a . :b)("a" . "b")))))
+--
+2.37.3
+