summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:36:44 +0300
commit322917aeb8e672c21378fd371a5cff4a9f0c2520 (patch)
tree70229faa39f14caa09b769153453c3898f64f7fc /gnu/packages/patches
parent407f017663c97ebfe48e3cb304bf97bf2557f83f (diff)
parente1baf802ccd8af4f7b416b0987db706f2dbfc42f (diff)
Merge remote-tracking branch 'origin/master' into staging
Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/giac-pari-gp-anyarg.patch28
-rw-r--r--gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch70
-rw-r--r--gnu/packages/patches/picard-fix-id3-rename-test.patch11
-rw-r--r--gnu/packages/patches/public-inbox-fix-spawn-test.patch43
-rw-r--r--gnu/packages/patches/python-louvain-fix-test.patch15
-rw-r--r--gnu/packages/patches/scotch-build-parallelism.patch39
-rw-r--r--gnu/packages/patches/scotch-integer-declarations.patch37
-rw-r--r--gnu/packages/patches/sssd-optional-systemd.patch24
8 files changed, 55 insertions, 212 deletions
diff --git a/gnu/packages/patches/giac-pari-gp-anyarg.patch b/gnu/packages/patches/giac-pari-gp-anyarg.patch
new file mode 100644
index 0000000000..0441f6bcf9
--- /dev/null
+++ b/gnu/packages/patches/giac-pari-gp-anyarg.patch
@@ -0,0 +1,28 @@
+From 041d16b521d8231e5b441015f08bb386f9d2a51c Mon Sep 17 00:00:00 2001
+From: Vincent Delecroix <20100.delecroix@gmail.com*>
+Date: Thu, 15 Sep 2022 12:11:01 +0200
+Subject: ANYARG giac patch
+
+---
+diff --git a/src/pari.cc b/src/pari.cc
+index 76ce8e1..50d08ab 100644
+--- a/src/pari.cc
++++ b/src/pari.cc
+@@ -40,6 +40,13 @@ using namespace std;
+
+ #ifdef HAVE_LIBPARI
+
++// Anyarg disappeared from PARI 2.15.0
++#ifdef __cplusplus
++# define ANYARG ...
++#else
++# define ANYARG
++#endif
++
+ #ifdef HAVE_PTHREAD_H
+ #include <pthread.h>
+ #endif
+
+--
+cgit v1.0-1-gd88e
+
diff --git a/gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch b/gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch
deleted file mode 100644
index 228adc23f1..0000000000
--- a/gnu/packages/patches/icecat-use-older-reveal-hidden-html.patch
+++ /dev/null
@@ -1,70 +0,0 @@
-From 2e8618d22568b6e00892a17303d437dd700eca98 Mon Sep 17 00:00:00 2001
-From: Mark H Weaver <mhw@netris.org>
-Date: Tue, 5 May 2020 21:27:41 -0400
-Subject: [PATCH] Revert "Update Reveal hidden HTML."
-
-I prefer the user interface of the old version.
-
-This reverts commit f6e3adb6b2344ee2c7bb453a305fd2d6fb4c194c.
----
- .../passive_improve_css.js | 23 ++++++++++++++-----
- 1 file changed, 17 insertions(+), 6 deletions(-)
-
-diff --git a/data/extensions/SubmitMe@0xbeef.coffee/passive_improve_css.js b/data/extensions/SubmitMe@0xbeef.coffee/passive_improve_css.js
-index 7692990..ca57982 100644
---- a/data/extensions/SubmitMe@0xbeef.coffee/passive_improve_css.js
-+++ b/data/extensions/SubmitMe@0xbeef.coffee/passive_improve_css.js
-@@ -10,6 +10,8 @@ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR IMPLI
- */
-
-
-+var bad = [];
-+
- function escapeHTML (unsafe_str) {
- return unsafe_str
- .replace(/&/g, '&amp;')
-@@ -20,9 +22,14 @@ function escapeHTML (unsafe_str) {
- .replace(/\//g, '&#x2F;')
- }
-
-+function dounhide(){
-+ for(var i = 0; i < bad.length; i++){
-+ bad[i].remove();
-+ }
-+}
-+
- console.log("passive_improve_css.js");
- function reveal_css(){
-- var bad = [];
-
- var elements = document.getElementsByTagName("style");
- for(var i = 0; i < elements.length; i++){
-@@ -41,16 +48,20 @@ function reveal_css(){
-
- }
- }
-- if(bad.length > 0 && window.confirm("Hidden HTML detected, would you like to reveal it?")){
-- for(var i = 0; i < bad.length; i++){
-- bad[i].remove();
-- }
-+ if(bad.length > 0){
-+ const insertedDiv = document.createElement('div');
-+ insertedDiv.innerHTML= '<p id="unhide" class="button white" style="text-decoration:none!important; color:#000!important; font-size:1em !important; font-family:\'sans-serif\'!important; font-weight:normal !important; background-color:transparent!important; margin:0!important; padding:0!important; font-size:10px!important; line-height:1!important"' +
-+ 'alt="Click to reveal hidden elements in this page">' +
-+ '<span>Reveal hidden elements</span>' +
-+ '</a>';
-+ insertedDiv.style="position:fixed; bottom:1em; right:1em; opacity:0.8; z-index: 2147483647 !important; border-radius: 3px !important; background-color: #fff !important; padding: 0.5em !important; box-shadow: 0 0 3px grey !important; font-color:#bbb!important; cursor: pointer!important;";
-+ insertedDiv.addEventListener("click", dounhide, false);
-+ document.body.insertBefore(insertedDiv, document.body.firstChild);
- }
- }
-
- reveal_css();
-
--
- /*
- var a = document.getElementsByTagName("style")[2];
- var btn = document.createElement("style"); // Create a <button> element
---
-2.26.2
-
diff --git a/gnu/packages/patches/picard-fix-id3-rename-test.patch b/gnu/packages/patches/picard-fix-id3-rename-test.patch
deleted file mode 100644
index 3c4fa63c84..0000000000
--- a/gnu/packages/patches/picard-fix-id3-rename-test.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-Index: b/test/formats/test_id3.py
-===================================================================
---- a/test/formats/test_id3.py
-+++ b/test/formats/test_id3.py
-@@ -266,5 +266,5 @@
- def test_rename_txxx_tags(self):
- file_path = os.path.join('test', 'data', 'test-id3-rename-tags.mp3')
-- filename = self.copy_file_tmp(file_path, 'mp3')
-+ filename = self.copy_file_tmp(file_path, '.mp3')
- raw_metadata = load_raw(filename)
- self.assertIn('TXXX:Artists', raw_metadata)
diff --git a/gnu/packages/patches/public-inbox-fix-spawn-test.patch b/gnu/packages/patches/public-inbox-fix-spawn-test.patch
deleted file mode 100644
index 2739b1974d..0000000000
--- a/gnu/packages/patches/public-inbox-fix-spawn-test.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 5593489d9c3ce22b1942f35c7ebb0e06fcf2bfa8 Mon Sep 17 00:00:00 2001
-From: Thiago Jung Bauermann <bauermann@kolabnow.com>
-Date: Fri, 10 Jun 2022 12:39:18 -0300
-Subject: [PATCH] t/spawn: Find invalid PID to try to join its process group
-
-In the container used to build packages of the GNU Guix distribution, PID 1
-runs as the same user as the test so this spawn that should fail actually
-succeeds.
-
-Fix the problem by going through different PIDs and picking one that
-either doesn't exist or we aren't allowed to signal.
----
-
-This patch is taken from the public-inbox repository and will appear in the
-release after v1.8.
-
- t/spawn.t | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/t/spawn.t b/t/spawn.t
-index 6168c1f6171c..5fc99a2a101c 100644
---- a/t/spawn.t
-+++ b/t/spawn.t
-@@ -24,7 +24,18 @@ SKIP: {
- is(waitpid($pid, 0), $pid, 'waitpid succeeds on spawned process');
- is($?, 0, 'true exited successfully');
- pipe(my ($r, $w)) or BAIL_OUT;
-- $pid = eval { spawn(['true'], undef, { pgid => 1, 2 => $w }) };
-+
-+ # Find invalid PID to try to join its process group.
-+ my $wrong_pgid = 1;
-+ for (my $i=0x7fffffff; $i >= 2; $i--) {
-+ if (kill(0, $i) == 0) {
-+ $wrong_pgid = $i;
-+ last;
-+ }
-+ }
-+
-+ # Test spawn behavior when it can't join the requested process group.
-+ $pid = eval { spawn(['true'], undef, { pgid => $wrong_pgid, 2 => $w }) };
- close $w;
- my $err = do { local $/; <$r> };
- # diag "$err ($@)";
diff --git a/gnu/packages/patches/python-louvain-fix-test.patch b/gnu/packages/patches/python-louvain-fix-test.patch
new file mode 100644
index 0000000000..2127df681c
--- /dev/null
+++ b/gnu/packages/patches/python-louvain-fix-test.patch
@@ -0,0 +1,15 @@
+https://github.com/taynaud/python-louvain/commit/638804ae636dc65306900ef6518ca0a1c9202566.diff
+
+diff --git a/test_community.py b/test_community.py
+index 1ee1976..566a4b1 100644
+--- a/test_community.py
++++ b/test_community.py
+@@ -203,7 +203,7 @@ def test_karate(self):
+ self.assertAlmostEqual(co.modularity(part, graph),
+ co.modularity(part_weight,
+ graph,
+- "test_weight"), places=2)
++ "test_weight"), places=1)
+
+ part_res_low = co.best_partition(graph, resolution=0.1)
+ self.assertTrue(
diff --git a/gnu/packages/patches/scotch-build-parallelism.patch b/gnu/packages/patches/scotch-build-parallelism.patch
deleted file mode 100644
index a669f1dbeb..0000000000
--- a/gnu/packages/patches/scotch-build-parallelism.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-Fixes make with -j, otherwise scotch.h may not be generated by the time make
-tries to compile library_graph_diam.o et al.
-
-Reported upstream at
-https://gforge.inria.fr/tracker/index.php?func=detail&aid=21651&group_id=248&atid=1081
-
-diff --git a/src/libscotch/Makefile b/src/libscotch/Makefile
-index 9898894..b0ee14c 100644
---- a/src/libscotch/Makefile
-+++ b/src/libscotch/Makefile
-@@ -2229,6 +2229,28 @@ library_graph_color_f$(OBJ) : library_graph_color_f.c \
- common.h \
- scotch.h
-
-+library_graph_diam$(OBJ) : library_graph_diam.c \
-+ module.h \
-+ common.h \
-+ graph.h \
-+ scotch.h
-+
-+library_graph_diam_f$(OBJ) : library_graph_diam.c \
-+ module.h \
-+ common.h \
-+ scotch.h
-+
-+library_graph_induce$(OBJ) : library_graph_diam.c \
-+ module.h \
-+ common.h \
-+ graph.h \
-+ scotch.h
-+
-+library_graph_induce_f$(OBJ) : library_graph_diam.c \
-+ module.h \
-+ common.h \
-+ scotch.h
-+
- library_graph_io_chac$(OBJ) : library_graph_io_chac.c \
- module.h \
- common.h \
diff --git a/gnu/packages/patches/scotch-integer-declarations.patch b/gnu/packages/patches/scotch-integer-declarations.patch
deleted file mode 100644
index 978625c1c0..0000000000
--- a/gnu/packages/patches/scotch-integer-declarations.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-diff --git a/src/libscotch/library.h b/src/libscotch/library.h
-index 1891c19..ecc0533 100644
---- a/src/libscotch/library.h
-+++ b/src/libscotch/library.h
-@@ -67,6 +67,8 @@
-
- /*+ Integer type. +*/
-
-+#include <stdint.h>
-+
- typedef DUMMYIDX SCOTCH_Idx;
-
- typedef DUMMYINT SCOTCH_Num;
-diff --git a/src/libscotchmetis/library_metis.h b/src/libscotchmetis/library_metis.h
-index e6767e1..04e71c3 100644
---- a/src/libscotchmetis/library_metis.h
-+++ b/src/libscotchmetis/library_metis.h
-@@ -99,6 +99,7 @@ typedef enum {
- */
-
- #ifndef SCOTCH_H /* In case "scotch.h" not included before */
-+#include <stdint.h>
- typedef DUMMYINT SCOTCH_Num;
- #endif /* SCOTCH_H */
-
-diff --git a/src/libscotchmetis/library_parmetis.h b/src/libscotchmetis/library_parmetis.h
-index 6d2f0b0..3c803fc 100644
---- a/src/libscotchmetis/library_parmetis.h
-+++ b/src/libscotchmetis/library_parmetis.h
-@@ -106,6 +106,7 @@ typedef enum {
- */
-
- #ifndef SCOTCH_H /* In case "scotch.h" not included before */
-+#include <stdint.h>
- typedef DUMMYINT SCOTCH_Num;
- #endif /* SCOTCH_H */
-
diff --git a/gnu/packages/patches/sssd-optional-systemd.patch b/gnu/packages/patches/sssd-optional-systemd.patch
index 0784fdc7aa..e6d74e79fa 100644
--- a/gnu/packages/patches/sssd-optional-systemd.patch
+++ b/gnu/packages/patches/sssd-optional-systemd.patch
@@ -2,7 +2,7 @@ Allow running sss_analyze without Python modules for systemd.
Upstream PR: https://github.com/SSSD/sssd/pull/6125
diff --git a/src/tools/analyzer/modules/request.py b/src/tools/analyzer/modules/request.py
-index b96a23c05..28ac2f194 100644
+index b9fe3caf8..51ec3a151 100644
--- a/src/tools/analyzer/modules/request.py
+++ b/src/tools/analyzer/modules/request.py
@@ -1,8 +1,6 @@
@@ -14,7 +14,7 @@ index b96a23c05..28ac2f194 100644
from sssd.parser import SubparsersAction
from sssd.parser import Option
-@@ -77,8 +75,10 @@ class RequestAnalyzer:
+@@ -76,8 +74,10 @@ class RequestAnalyzer:
Instantiated source object
"""
if args.source == "journald":
@@ -25,7 +25,7 @@ index b96a23c05..28ac2f194 100644
source = Files(args.logdir)
return source
-@@ -143,7 +143,7 @@ class RequestAnalyzer:
+@@ -142,7 +142,7 @@ class RequestAnalyzer:
self.consumed_logs.append(line.rstrip(line[-1]))
else:
# files source includes newline
@@ -34,12 +34,12 @@ index b96a23c05..28ac2f194 100644
print(line, end='')
else:
print(line)
-@@ -225,7 +225,7 @@ class RequestAnalyzer:
- source.set_component(component, False)
- self.done = ""
- for line in self.matched_line(source, patterns):
-- if isinstance(source, Journald):
-+ if type(source).__name__ == 'Journald':
- print(line)
- else:
- self.print_formatted(line, args.verbose)
+@@ -240,7 +240,7 @@ class RequestAnalyzer:
+ self.print_formatted_verbose(source, patterns)
+ else:
+ for line in self.matched_line(source, patterns):
+- if isinstance(source, Journald):
++ if type(source).__name__ == 'Journald':
+ print(line)
+ else:
+ self.print_formatted(line)