summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2022-09-14 14:48:46 +0200
committerMarius Bakke <marius@gnu.org>2022-09-16 18:42:21 +0200
commit6ce5a6c2e34d5053fcd02883059ea16ca2ad5a75 (patch)
tree7837d30cb9b841ee8e88fb69921ca85eab9a9b1e /gnu/packages/patches
parentfa0efe133e5ba0313054699e6ee45a55f348ec3e (diff)
gnu: antlr4: Update to 4.10.1.
* gnu/packages/java.scm (java-antlr4-runtime): Update to 4.10.1. [source](patches): Remove obsolete patch. (java-antlr4-runtime-cpp): Add #:configure-flags. (antlr4)[arguments]: Don't run tests from removed directory. Enable one test; exclude one file. * gnu/packages/fontutils.scm (python-afdko)[arguments]: Add phase to build with the C++ 17 standard.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/java-antlr4-fix-code-too-large.java90
1 files changed, 0 insertions, 90 deletions
diff --git a/gnu/packages/patches/java-antlr4-fix-code-too-large.java b/gnu/packages/patches/java-antlr4-fix-code-too-large.java
deleted file mode 100644
index 9e9f92349d..0000000000
--- a/gnu/packages/patches/java-antlr4-fix-code-too-large.java
+++ /dev/null
@@ -1,90 +0,0 @@
-From d22db2048534bdf3d9615117291f9d86564ff10d Mon Sep 17 00:00:00 2001
-From: Julien Lepiller <julien@lepiller.eu>
-Date: Sat, 19 Sep 2020 21:05:48 +0200
-Subject: [PATCH] Separate addPropertyAliases in two methods
-
-The quantity of data used to generate addPropertyAliases creates a big
-method, that is too big for java and results in "error: code too large".
-This is most likely due to added data between the expected version of
-icu and the actual version of icu in Guix.
----
- .../org/antlr/v4/tool/templates/unicodedata.st | 17 ++++++++++++++---
- .../unicode/UnicodeDataTemplateController.java | 18 ++++++++++--------
- 2 files changed, 24 insertions(+), 11 deletions(-)
-
-diff --git a/tool/resources/org/antlr/v4/tool/templates/unicodedata.st b/tool/resources/org/antlr/v4/tool/templates/unicodedata.st
-index 0f22c73..3573873 100644
---- a/tool/resources/org/antlr/v4/tool/templates/unicodedata.st
-+++ b/tool/resources/org/antlr/v4/tool/templates/unicodedata.st
-@@ -1,4 +1,4 @@
--unicodedata(propertyCodePointRanges, propertyAliases) ::= <<
-+unicodedata(propertyCodePointRanges, propertyAliasesA, propertyAliasesB) ::= <<
- package org.antlr.v4.unicode;
-
- import java.util.Arrays;
-@@ -15,7 +15,7 @@ import org.antlr.v4.runtime.misc.Interval;
- */
- public abstract class UnicodeData {
- private static final Map\<String, IntervalSet\> propertyCodePointRanges = new HashMap\<\>(<length(propertyCodePointRanges)>);
-- private static final Map\<String, String\> propertyAliases = new HashMap\<\>(<length(propertyAliases)>);
-+ private static final Map\<String, String\> propertyAliases = new HashMap\<\>(<length(propertyAliasesA)> + <length(propertyAliasesB)>);
-
- // Work around Java 64k bytecode method limit by splitting up static
- // initialization into one method per Unicode property
-@@ -30,9 +30,20 @@ static private void addProperty<i>() {
- propertyCodePointRanges.put("<k>".toLowerCase(Locale.US), codePointRanges);
- \}}; separator="\n\n">
-
-+ // Property aliases
-+ static private void addPropertyAliases1() {
-+ <propertyAliasesA.keys:{ k | propertyAliases.put("<k>".toLowerCase(Locale.US), "<propertyAliasesA.(k)>".toLowerCase(Locale.US)); }; separator="\n">
-+ }
-+
-+ // Property aliases
-+ static private void addPropertyAliases2() {
-+ <propertyAliasesB.keys:{ k | propertyAliases.put("<k>".toLowerCase(Locale.US), "<propertyAliasesB.(k)>".toLowerCase(Locale.US)); }; separator="\n">
-+ }
-+
- // Property aliases
- static private void addPropertyAliases() {
-- <propertyAliases.keys:{ k | propertyAliases.put("<k>".toLowerCase(Locale.US), "<propertyAliases.(k)>".toLowerCase(Locale.US)); }; separator="\n">
-+ addPropertyAliases1();
-+ addPropertyAliases2();
- }
-
- // Put it all together
-diff --git a/tool/src/org/antlr/v4/unicode/UnicodeDataTemplateController.java b/tool/src/org/antlr/v4/unicode/UnicodeDataTemplateController.java
-index da244a3..dc591cb 100644
---- a/tool/src/org/antlr/v4/unicode/UnicodeDataTemplateController.java
-+++ b/tool/src/org/antlr/v4/unicode/UnicodeDataTemplateController.java
-@@ -78,17 +78,19 @@ public abstract class UnicodeDataTemplateController {
- addTR35ExtendedPictographicPropertyCodesToCodePointRanges(propertyCodePointRanges);
- addEmojiPresentationPropertyCodesToCodePointRanges(propertyCodePointRanges);
-
-- Map<String, String> propertyAliases = new LinkedHashMap<>();
-- addUnicodeCategoryCodesToNames(propertyAliases);
-- addUnicodeBinaryPropertyCodesToNames(propertyAliases);
-- addUnicodeScriptCodesToNames(propertyAliases);
-- addUnicodeBlocksToNames(propertyAliases);
-- addUnicodeIntPropertyCodesToNames(propertyAliases);
-- propertyAliases.put("EP", "Extended_Pictographic");
-+ Map<String, String> propertyAliases1 = new LinkedHashMap<>();
-+ Map<String, String> propertyAliases2 = new LinkedHashMap<>();
-+ addUnicodeCategoryCodesToNames(propertyAliases1);
-+ addUnicodeBinaryPropertyCodesToNames(propertyAliases1);
-+ addUnicodeScriptCodesToNames(propertyAliases1);
-+ addUnicodeBlocksToNames(propertyAliases2);
-+ addUnicodeIntPropertyCodesToNames(propertyAliases2);
-+ propertyAliases2.put("EP", "Extended_Pictographic");
-
- Map<String, Object> properties = new LinkedHashMap<>();
- properties.put("propertyCodePointRanges", propertyCodePointRanges);
-- properties.put("propertyAliases", propertyAliases);
-+ properties.put("propertyAliasesA", propertyAliases1);
-+ properties.put("propertyAliasesB", propertyAliases2);
- return properties;
- }
-
---
-2.28.0
-