summaryrefslogtreecommitdiff
path: root/gnu/packages/patchutils.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-09-10 10:43:41 -0500
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2022-09-11 12:35:29 +0200
commit2e50fd2301ffc6d0d8bfeab87edb88cca88d0b9a (patch)
tree8c49b1240aaaea11daee998b0c167da605ff33e5 /gnu/packages/patchutils.scm
parent072cc8d1415a2abf66b36249c61658a828dead88 (diff)
gnu: Add wiggle.
* gnu/packages/patchutils.scm (wiggle): New variable. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
Diffstat (limited to 'gnu/packages/patchutils.scm')
-rw-r--r--gnu/packages/patchutils.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index fdbcb8e1e1..dd5e6bae9a 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2018–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,6 +22,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages patchutils)
+ #:use-module (guix gexp)
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix licenses)
@@ -40,6 +42,7 @@
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages groff)
#:use-module (gnu packages gtk)
#:use-module (gnu packages less)
#:use-module (gnu packages mail)
@@ -441,6 +444,41 @@ Users can login allowing them to change the state of patches.")
(home-page "http://jk.ozlabs.org/projects/patchwork/")
(license gpl2+)))
+(define-public wiggle
+ (package
+ (name "wiggle")
+ (version "1.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/neilbrown/wiggle")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18ilzr9sbal1j8p1d94ilm1j5blac5cngvcvjpdmgmpw6diy2ldf"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list "CFLAGS=-I. -O3" "INSTALL=install" "STRIP=-s"
+ (string-append "CC=" #$(cc-for-target))
+ (string-append "BINDIR=" #$output "/bin")
+ (string-append "MANDIR=" #$output "/share/man")
+ (string-append "PREFIX=" #$output))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure))))
+ (home-page "http://neil.brown.name/wiggle/")
+ (inputs (list ncurses))
+ (native-inputs (list groff))
+ (synopsis "Apply patches with conflicts")
+ (description
+ "@code{wiggle} attempts to apply patches to a target file even if the
+patches do not match perfectly.")
+ (license gpl2+)))
+
(define-public pwclient
(package
(name "pwclient")