summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-01 13:55:04 +0300
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 15:02:57 -0400
commit68ec0bafc9760713c0a891cd57fad9ba13ca7111 (patch)
tree9533b83150f5e0fb54f1468da680063339390370 /gnu/packages/pcre.scm
parentb0e84b89da3d3865c174344decbc45256c64b4bc (diff)
gnu: pcre: Enable JIT on powerpc-linux.
* gnu/packages/pcre.scm (pcre)[arguments]: When building for powerpc-linux use the compile flag to enable jit support.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7c53a27685..bc1e7a73e0 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -64,9 +64,8 @@
"--enable-unicode-properties"
"--enable-pcre16"
"--enable-pcre32"
- ;; pcretest fails on powerpc32.
;; riscv64-linux is an unsupported architecture.
- #$@(if (or (target-ppc32?) (target-riscv64?))
+ #$@(if (target-riscv64?)
#~()
#~("--enable-jit")))
#:phases