summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-08-01 13:55:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-08-02 09:20:40 +0300
commitb89be0f5d2f831c36e217c67461a2b2cf277529f (patch)
tree94cb689cf9c3b9023fc42bd6ff475f2a67ed51fc /gnu/packages/pcre.scm
parent2d8fac3fd9f0914cd5e420318f6b16399a355e9c (diff)
gnu: pcre: Enable JIT on powerpc-linux.
* gnu/packages/pcre.scm (pcre)[arguments]: When building for powerpc-linux use the compile flag to enable jit support.
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 7c53a27685..bc1e7a73e0 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -64,9 +64,8 @@
"--enable-unicode-properties"
"--enable-pcre16"
"--enable-pcre32"
- ;; pcretest fails on powerpc32.
;; riscv64-linux is an unsupported architecture.
- #$@(if (or (target-ppc32?) (target-riscv64?))
+ #$@(if (target-riscv64?)
#~()
#~("--enable-jit")))
#:phases