summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2023-12-12 20:38:37 +0000
committerLudovic Courtès <ludo@gnu.org>2023-12-23 11:17:49 +0100
commite008a1baca7f8c71d63367a4e9e192d3be5dc786 (patch)
tree5763a751e2cf0d7f63c1db4952c708ba5d818c5c /gnu/packages/pdf.scm
parent2c8cdb05502cacaf603da231796ccafa59671117 (diff)
gnu: Add unpaper.
* gnu/packages/pdf.scm (unpaper): New variable. Change-Id: Ic71c5b62dabdd18e617e499417afb1c9e112520b Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 874076effb..644a4617a6 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -24,6 +24,7 @@
;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
+;;; Copyright © 2023 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -107,6 +108,7 @@
#:use-module (gnu packages time)
#:use-module (gnu packages tcl)
#:use-module (gnu packages tls)
+ #:use-module (gnu packages video)
#:use-module (gnu packages web)
#:use-module (gnu packages webkit)
#:use-module (gnu packages xdisorg)
@@ -976,6 +978,34 @@ configurable toolbars and shortcuts, continuous and multi‐page layouts,
SyncTeX support, and rudimentary support for annotations and forms.")
(license license:gpl2+)))
+(define-public unpaper
+ (package
+ (name "unpaper")
+ (version "7.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.flameeyes.com/files/unpaper-"
+ version ".tar.xz"))
+ (sha256
+ (base32 "103awjdl2qrzi0qc32hi8zvwf04r5ih5jaw8rg8ij9y24szznx95"))))
+ (native-inputs
+ (list pkg-config python-sphinx))
+ (inputs
+ (list discount ffmpeg))
+ (build-system meson-build-system)
+ (home-page "https://www.flameeyes.com/projects/unpaper")
+ (synopsis "post-processing tool for scanned pages")
+ (description "@command{unpaper} is a post-processing tool for
+scanned sheets of paper, especially for book pages that have been
+scanned from previously created photocopies.
+
+Its main purpose is to make scanned book pages better readable on screen
+after conversion to PDF. Additionally, unpaper might be useful to
+enhance the quality of scanned pages before performing
+@acronym{OCR, optical character recognition}.")
+ (license license:gpl2)))
+
(define-public xournal
(package
(name "xournal")