summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-03-19 20:41:47 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-01 07:13:49 +0200
commitaac2006d8276ac7ed3876b879f1816e57379aa25 (patch)
treefa25e51d01fac3381eb9c3215db1608081bed228 /gnu/packages/pdf.scm
parent7d475dd4ece966faae71323f309b65314b27a5a3 (diff)
gnu: zathura-pdf-mupdf: Update to 0.3.3.
* gnu/packages/pdf.scm (zathura-pdf-mupdf): Update to 0.3.3. [build-system]: Switch to the Meson build system. [arguments]: Trim accordingly. Add a new ‘patch-plugin-directory’ phase.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm25
1 files changed, 16 insertions, 9 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 151143aa31..6ca1895aed 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -420,15 +420,15 @@ using the DjVuLibre library.")
(define-public zathura-pdf-mupdf
(package
(name "zathura-pdf-mupdf")
- (version "0.3.2")
+ (version "0.3.3")
(source (origin
(method url-fetch)
(uri
(string-append "https://pwmt.org/projects/zathura-pdf-mupdf"
- "/download/zathura-pdf-mupdf-" version ".tar.gz"))
+ "/download/zathura-pdf-mupdf-" version ".tar.xz"))
(sha256
(base32
- "0xkajc3is7ncmb2fmymbzfgrran2bz12i7zsm1vvxhxds728h7ck"))))
+ "1zbdqimav4wfgimpy3nfzl10qj7vyv23rdy2z5z7z93jwbp2rc2j"))))
(native-inputs `(("pkg-config" ,pkg-config)))
(inputs
`(("jbig2dec" ,jbig2dec)
@@ -437,13 +437,20 @@ using the DjVuLibre library.")
("openjpeg" ,openjpeg)
("openssl" ,openssl)
("zathura" ,zathura)))
- (build-system gnu-build-system)
+ (build-system meson-build-system)
(arguments
- `(#:make-flags (list (string-append "PREFIX=" %output)
- (string-append "PLUGINDIR=" %output "/lib/zathura")
- "CC=gcc")
- #:tests? #f ;No tests.
- #:phases (modify-phases %standard-phases (delete 'configure))))
+ `(#:tests? #f ; package does not contain tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-plugin-directory
+ ;; Something of a regression in 0.3.3: the new Meson build system
+ ;; now hard-codes an incorrect plugin directory. Fix it.
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "meson.build"
+ (("(install_dir:).*" _ key)
+ (string-append key
+ "'" (assoc-ref outputs "out") "/lib/zathura'\n")))
+ #t)))))
(home-page "https://pwmt.org/projects/zathura-pdf-mupdf/")
(synopsis "PDF support for zathura (mupdf backend)")
(description "The zathura-pdf-mupdf plugin adds PDF support to zathura