summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-08-17 23:21:00 -0400
committerLeo Famulari <leo@famulari.name>2016-08-17 23:35:22 -0400
commit015ee84aac888b3900fa0ee54a1b7e55c083e7d3 (patch)
tree2ef7a51321dff53e479bc6d11f3785e1c65c07f0 /gnu/packages/pdf.scm
parenta3d6e1f432ad5f9cde8bee670b28646e05c4cb19 (diff)
parent79f9d5d5dc97e492e0583e039a2699aa17f4eb11 (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4757ef7534..3c267fb121 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Coypright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Coypright © 2016 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -50,6 +51,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages pcre)
#:use-module (gnu packages perl)
+ #:use-module (gnu packages python)
#:use-module (gnu packages tls)
#:use-module (srfi srfi-1))
@@ -583,3 +585,35 @@ program capable of converting PDF into other formats.")
"Xournal is an application for notetaking, sketching, keeping a journal
using a stylus.")
(license license:gpl2+)))
+
+(define-public python-reportlab
+ (package
+ (name "python-reportlab")
+ (version "3.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "reportlab" version))
+ (sha256
+ (base32
+ "0rz2pg04wnzjjm2f5a8ik9v8s54mv4xrjhv5liqjijqv6awh12gl"))))
+ (build-system python-build-system)
+ (arguments
+ ;; Prevent creation of the egg. Without this flag, various artifacts
+ ;; from the build inputs end up in the final python3 output. It also
+ ;; works around https://debbugs.gnu.org/cgi/bugreport.cgi?bug=20765 .
+ `(#:configure-flags '("--single-version-externally-managed" "--root=/")))
+ (propagated-inputs
+ `(("python-pillow" ,python-pillow)))
+ (home-page "http://www.reportlab.com")
+ (synopsis "Python library for generating PDFs and graphics")
+ (description "This is the ReportLab PDF Toolkit. It allows rapid creation
+of rich PDF documents, and also creation of charts in a variety of bitmap and
+vector formats.")
+ (license license:bsd-3)
+ (properties `((python2-variant . ,(delay python2-reportlab))))))
+
+(define-public python2-reportlab
+ (package
+ (inherit (package-with-python2
+ (strip-python2-variant python-reportlab)))
+ (native-inputs `(("python2-pip" ,python2-pip)))))