summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-02 15:41:46 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-02 17:57:55 +0200
commit503409b543186df5839f7029a42acff50cc53761 (patch)
treec98d4b52e4c3572ded6f0a9baeb1e413bee448df /gnu/packages/pdf.scm
parent6d49ca3bad613700b539c30272e164207455735b (diff)
gnu: qpdf: Remove run-time dependency on Perl.
* gnu/packages/pdf.scm (qpdf)[source](snippet): New field. [arguments]: Add #:disallowed-references. [inputs]: Move PERL to... [native-inputs]: ... here.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm41
1 files changed, 26 insertions, 15 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 8f9f5dd503..cfa9a9c2e6 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -471,27 +471,38 @@ and examining the file structure (pdfshow).")
(uri (string-append "mirror://sourceforge/qpdf/qpdf-"
version ".tar.gz"))
(sha256 (base32
- "1lq1v7xghvl6p4hgrwbps3a13ad6lh4ib3myimb83hxgsgd4n5nm"))))
+ "1lq1v7xghvl6p4hgrwbps3a13ad6lh4ib3myimb83hxgsgd4n5nm"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; Replace shebang with the bi-lingual shell/Perl trick to remove
+ ;; dependency on Perl.
+ '(substitute* "qpdf/fix-qdf"
+ (("#!/usr/bin/env perl")
+ "\
+eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
+ & eval 'exec perl -wS \"$0\" $argv:q'
+ if 0;\n")))))
(build-system gnu-build-system)
(arguments
- '(#:phases (alist-cons-before
- 'configure 'patch-paths
- (lambda _
- (substitute* "make/libtool.mk"
- (("SHELL=/bin/bash")
- (string-append "SHELL=" (which "bash"))))
- (substitute* (append
- '("qtest/bin/qtest-driver")
- (find-files "." "\\.test"))
- (("/usr/bin/env") (which "env"))))
- %standard-phases)))
+ `(#:disallowed-references (,perl)
+ #:phases (alist-cons-before
+ 'configure 'patch-paths
+ (lambda _
+ (substitute* "make/libtool.mk"
+ (("SHELL=/bin/bash")
+ (string-append "SHELL=" (which "bash"))))
+ (substitute* (append
+ '("qtest/bin/qtest-driver")
+ (find-files "." "\\.test"))
+ (("/usr/bin/env") (which "env"))))
+ %standard-phases)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("perl" ,perl)))
(propagated-inputs
`(("pcre" ,pcre)))
(inputs
- `(("zlib" ,zlib)
- ("perl" ,perl)))
+ `(("zlib" ,zlib)))
(synopsis "Command-line tools and library for transforming PDF files")
(description
"QPDF is a command-line program that does structural, content-preserving