summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@reproducible-builds.org>2023-01-21 23:03:39 -0800
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-22 19:40:10 -0500
commitf8400b2cbd7acab5aec04d19396adaf04296746d (patch)
tree3a6d2ab3e1f7a439a7b1fde228d58c19e79dc260 /gnu/packages/pdf.scm
parent356e33641a35f32a87f7c2eb20666d848dd7e44f (diff)
gnu: Add python-pypdf.
* gnu/packages/pdf.scm (python-pypdf): New variable. * gnu/packages/patches/python-pypdf-annotate-tests-appropriately.patch: New file. * gnu/local.mk (dist_patch_DATA): Register patch. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 4b9d0623fe..8f3bec35d6 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -1260,6 +1260,35 @@ documents that use the standard security handler.")
converter using the Poppler and Cairo libraries.")
(license license:gpl2+)))
+(define-public python-pypdf
+ (package
+ (name "python-pypdf")
+ (version "3.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/py-pdf/pypdf")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1qwvjr694sabfblx22zd54b9ny40f2gbv3bv6q43myrlxwvvisk6"))
+ (patches (search-patches
+ "python-pypdf-annotate-tests-appropriately.patch"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest python-flit))
+ (propagated-inputs (list python-typing-extensions))
+ (home-page "https://github.com/py-pdf/pypdf")
+ (arguments
+ (list
+ ;; Disable tests that use the network and non-free assets.
+ #:test-flags #~(list "-m" "not external and not samples")))
+ (synopsis "Python PDF library")
+ (description
+ "This package provides a PDF library capable of splitting, merging,
+cropping, and transforming PDF files.")
+ (license license:bsd-3)))
+
(define-public python-pypdf2
(package
(name "python-pypdf2")