summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEuAndreh <eu@euandre.org>2022-10-17 22:38:14 -0300
committerChristopher Baines <mail@cbaines.net>2022-10-18 10:58:48 +0100
commit2a531bfb3445d723bfb915576e266f2094936aef (patch)
tree1f2c7692f3ada21e6773f5dfaa4a994b1bbd2c1d /gnu/packages/perl.scm
parentb91a5667c61bd9c55e70dd86418ccf0a5040736a (diff)
gnu: Add perl-string-format.
* gnu/packages/perl.scm (perl-string-format): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 15138d453f..31b2abde48 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9488,6 +9488,30 @@ expanding standard C/Unix-style backslash escapes like \n and \t, wrapping and
removing double-quotes, and truncating to fit within a desired length.")
(license (package-license perl))))
+(define-public perl-string-format
+ (package
+ (name "perl-string-format")
+ (version "1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SR/SREZIC/String-Format-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y77frxzjifd4sw0j19cc346ysas1mya84rdxaz279lyin7plhcy"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/String-Format")
+ (synopsis "Format sprintf-like strings with arbitrary format definitions")
+ (description
+ "@code{String::Format} lets you define arbitrary printf-like format
+sequences to be expanded. This module would be most useful in configuration
+files and reporting tools, where the results of a query need to be formatted in
+a particular way. It was inspired by
+@url{http://www.mutt.org/doc/manual/manual.html#index-format,mutt's
+@code{index_format} and related directives}.")
+ (license license:gpl2)))
+
(define-public perl-string-formatter
(package
(name "perl-string-formatter")