summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-10-12 14:36:44 +0300
commit322917aeb8e672c21378fd371a5cff4a9f0c2520 (patch)
tree70229faa39f14caa09b769153453c3898f64f7fc /gnu/packages/perl.scm
parent407f017663c97ebfe48e3cb304bf97bf2557f83f (diff)
parente1baf802ccd8af4f7b416b0987db706f2dbfc42f (diff)
Merge remote-tracking branch 'origin/master' into staging
Conflicts: gnu/packages/gnuzilla.scm gnu/packages/graphics.scm gnu/packages/gstreamer.scm gnu/packages/gtk.scm gnu/packages/kde-frameworks.scm gnu/packages/video.scm
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 6eab98ab74..b5944eb0dc 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -11641,6 +11641,28 @@ method calls. Furthermore, a partial sequence can be created and held, and
used as the head of many different sequences.")
(license license:perl-license)))
+(define-public perl-file-fcntllock
+ (package
+ (name "perl-file-fcntllock")
+ (version "0.22")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JT/JTT/File-FcntlLock-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1pxwknq4lw0wqpkh8pf18qsjf9g503vx6a5184vvffprzwpbp6ls"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/File-FcntlLock")
+ (synopsis "File locking with fcntl(2)")
+ (description "File locking in Perl is usually done using the @code{flock}
+function. Unfortunately, this only allows locks on whole files and is often
+implemented in terms of the @code{flock(2)} system function which has some
+shortcomings (especially concerning locks on remotely mounted file systems)
+and slightly different behaviour than @code{fcntl(2)}.")
+ (license license:perl-license)))
+
(define-public perl-font-ttf
(package
(name "perl-font-ttf")