summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorgemmaro <gemmaro.dev@gmail.com>2022-12-31 23:04:59 +0900
committerJulien Lepiller <julien@lepiller.eu>2023-01-03 20:51:52 +0100
commitc304d22d69e63956493b67a5624c4c06d3be2385 (patch)
tree6e60eff3f3abada053366be44392a821468c0de7 /gnu/packages/perl.scm
parentfe2626b4b371773518ace972ce3cde55198a4380 (diff)
gnu: Add perl-syntax-keyword-try
* gnu/packages/perl.scm (perl-syntax-keyword-try): New variable. Signed-off-by: Julien Lepiller <julien@lepiller.eu>
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 08db4909ec..7cdc052cee 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9997,6 +9997,30 @@ mechanism. The module augments the standard Perl syntax with two new
statements: @code{switch} and @code{case}.")
(license (package-license perl))))
+(define-public perl-syntax-keyword-try
+ (package
+ (name "perl-syntax-keyword-try")
+ (version "0.28")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/P/PE/PEVANS/Syntax-Keyword-Try-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1j02z9w0p9a77maf62cy5324vmc01hks0bfm5qjidc50hafmzbfc"))))
+ (build-system perl-build-system)
+ (native-inputs (list perl-module-build))
+ (inputs (list perl-xs-parse-keyword))
+ (home-page "https://metacpan.org/pod/Syntax::Keyword::Try")
+ (synopsis "Try/catch/finally syntax for perl")
+ (description
+ "This module provides a syntax plugin that implements
+exception-handling semantics in a form familiar to users of other
+languages, being built on a block labeled with the @code{try} keyword,
+followed by at least one of a @code{catch} or @code{finally} block.")
+ (license (package-license perl))))
+
(define-public perl-sys-cpu
(package
(name "perl-sys-cpu")