summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:03 +0200
commit288a5294d78c283f759c9d8a077c0e2240904ccf (patch)
treed1d977deeb93a5a2e56d4e3ba0e6f359ad97709d /gnu/packages/perl.scm
parent40f9e720a27528f5de3079aba67f687be59a9f7f (diff)
gnu: Add perl-cryptx.
* gnu/packages/perl.scm (perl-cryptx): New public variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 57852a3cee..6f30bd0795 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2560,6 +2560,25 @@ used in @code{crypt} are also supplied separately.")
;; Files in the 'fcrypt' directory are covered by a BSD licence.
(license (list license:perl-license license:bsd-3))))
+(define-public perl-cryptx
+ (package
+ (name "perl-cryptx")
+ (version "0.078")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/M/MI/MIK/CryptX-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1gdw33k8h7izjfb4zy9j1qfq4ffbqzpvhcf9ncy79mgp8890n5lk"))))
+ (build-system perl-build-system)
+ (home-page "https://metacpan.org/release/CryptX")
+ (synopsis "Self-contained cryptographic toolkit based on LibTomCrypt")
+ (description
+ "These self-contained Perl modules provide cryptography based on the
+LibTomCrypt library.")
+ (license license:perl-license)))
+
(define-public perl-cwd-guard
(package
(name "perl-cwd-guard")