summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-17 14:12:43 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-19 16:43:30 -0500
commit207d9126aa844876579d5bb4e7f00e21f42f333d (patch)
tree6689923fc7f1429abb547de762f7bf0694c58a8b /gnu/packages/perl.scm
parentff80a4a7fc5ef8805a5ea41c31ec6876f435df70 (diff)
gnu: Add Carp-Assert.
* gnu/packages/perl.scm (perl-carp-assert): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index dc2f7ecdec..85bdea2f0d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -256,6 +256,25 @@ code or from an external program. Optionally, output can be teed so that it
is captured while being passed through to the original file handles.")
(license asl2.0)))
+(define-public perl-carp-assert
+ (package
+ (name "perl-carp-assert")
+ (version "0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/N/NE/NEILB/"
+ "Carp-Assert-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0km5fc6r6whxh6h5yd7g1j0bi96sgk0gkda6cardicrw9qmqwkwj"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Carp-Assert")
+ (synopsis "Executable comments for Perl")
+ (description "Carp::Assert is intended for a purpose like the ANSI C
+library assert.h.")
+ (license (package-license perl))))
+
(define-public perl-carp-clan
(package
(name "perl-carp-clan")