summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-16 01:57:06 -0400
committerMark H Weaver <mhw@netris.org>2018-03-16 05:02:12 -0400
commit607f050bec1839499a674e0522ce5f60f73076f7 (patch)
tree8fe7e2002a918fbd64c4d7117ccb17fb9097374a /gnu/packages/perl.scm
parent4e50f1f2d3cd6e60c1370c62d699ed6ac6460275 (diff)
gnu: perl: Use invoke instead of system*.
* gnu/packages/perl.scm (perl)[arguments]: Use invoke. Return a boolean from all phase procedures.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index cf9f21dbc9..965bead418 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016, 2017 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
-;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2016 Jochem Raat <jchmrt@riseup.net>
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 ng0 <ng0@infotropique.org>
@@ -107,7 +107,7 @@
(replace 'configure
(lambda* (#:key configure-flags #:allow-other-keys)
(format #t "Perl configure flags: ~s~%" configure-flags)
- (zero? (apply system* "./Configure" configure-flags))))
+ (apply invoke "./Configure" configure-flags)))
(add-before
'strip 'make-shared-objects-writable
(lambda* (#:key outputs #:allow-other-keys)
@@ -117,7 +117,8 @@
(lib (string-append out "/lib")))
(for-each (lambda (dso)
(chmod dso #o755))
- (find-files lib "\\.so$")))))
+ (find-files lib "\\.so$"))
+ #t)))
(add-after 'install 'remove-extra-references
(lambda* (#:key inputs outputs #:allow-other-keys)