summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-03 15:16:42 +0200
committerRoel Janssen <roel@gnu.org>2018-04-03 15:16:42 +0200
commit7ba22308975f31c33d7a9cbb5c09be1837a74d2a (patch)
tree93a7a15e9fc217f82247fec3bffc01c603b14b13 /gnu/packages/perl.scm
parent9dfa3d22645a3f1e147bc8e765619c88abd40ea9 (diff)
gnu: Add perl-carp.
* gnu/packages/perl.scm (perl-carp): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 78c15f3339..8cb584c30d 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -722,6 +722,31 @@ is captured while being passed through to the original file handles.")
to test the installed perl for compatibility with his modules.")
(license (package-license perl))))
+(define-public perl-carp
+ (package
+ (name "perl-carp")
+ (version "1.38")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/R/RJ/RJBS/Carp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00bijwwc0ix27h2ma3lvsf3b56biar96bl9dikxgx7cmpcycxad5"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Carp/")
+ (synopsis "Alternative warn and die for modules")
+ (description "The @code{Carp} routines are useful in your own modules
+because they act like @code{die()} or @code{warn()}, but with a message
+which is more likely to be useful to a user of your module. In the case
+of @code{cluck}, @code{confess}, and @code{longmess} that context is a
+summary of every call in the call-stack. For a shorter message you can use
+@code{carp} or @code{croak} which report the error as being from where your
+module was called. There is no guarantee that that is where the error was,
+but it is a good educated guess.")
+ (license (package-license perl))))
+
(define-public perl-carp-always
(package
(name "perl-carp-always")