summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2018-04-03 14:43:13 +0200
committerRoel Janssen <roel@gnu.org>2018-04-03 14:43:13 +0200
commit9dfa3d22645a3f1e147bc8e765619c88abd40ea9 (patch)
tree779bec459171ca567269701fadc015846cfc79fc /gnu/packages/perl.scm
parent229241b1a47bcd5c366fdefab2dcbe233496d5d6 (diff)
gnu: Add perl-inline-c.
* gnu/packages/perl.scm (perl-inline-c): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 041db7a470..78c15f3339 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
-;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016, 2018 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2017 Raoul J.P. Bonnal <ilpuccio.febo@gmail.com>
@@ -3999,6 +3999,38 @@ module. The code is automatically compiled as needed, and then loaded
for immediate access from Perl.")
(license (package-license perl))))
+(define-public perl-inline-c
+ (package
+ (name "perl-inline-c")
+ (version "0.78")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/T/TI/TINITA/Inline-C-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1izv7vswd17glffh8h83bi63gdk208mmhxi17l3qd8q1bkc08y4s"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-file-copy-recursive" ,perl-file-copy-recursive)
+ ("perl-file-sharedir-install" ,perl-file-sharedir-install)
+ ("perl-test-warn" ,perl-test-warn)
+ ("perl-yaml-libyaml" ,perl-yaml-libyaml)))
+ (propagated-inputs
+ `(("perl-inline" ,perl-inline)
+ ("perl-parse-recdescent" ,perl-parse-recdescent)
+ ("perl-pegex" ,perl-pegex)))
+ (home-page "http://search.cpan.org/dist/Inline-C/")
+ (synopsis "C Language Support for Inline")
+ (description "The @code{Inline::C} module allows you to write Perl
+subroutines in C. Since version 0.30 the @code{Inline} module supports
+multiple programming languages and each language has its own support module.
+This document describes how to use Inline with the C programming language.
+It also goes a bit into Perl C internals.")
+ (license (package-license perl))))
+
(define-public perl-io-captureoutput
(package
(name "perl-io-captureoutput")