summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-19 20:28:56 -0400
committerMark H Weaver <mhw@netris.org>2015-07-19 20:28:56 -0400
commite170571887dc072edae8b197527921c47743c62c (patch)
treec77e6d7ff744c50cd2741fd92a0c73503daa83c2 /gnu/packages/perl.scm
parentdcd9c2505c0230c13556e233dbe4d81604a4abbd (diff)
parent1b4e48d498a96d478baa1aae7d9c7ecdbd817d6f (diff)
Merge branch 'core-updates'
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 900d25498c..7a8f832355 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -72,7 +72,15 @@
"-Dinstallstyle=lib/perl5"
"-Duseshrplib"
(string-append "-Dlocincpth=" libc "/include")
- (string-append "-Dloclibpth=" libc "/lib"))))))
+ (string-append "-Dloclibpth=" libc "/lib")
+
+ ;; Force the library search path to contain only libc
+ ;; because it is recorded in Config.pm and
+ ;; Config_heavy.pl; we don't want to keep a reference
+ ;; to everything that's in $LIBRARY_PATH at build
+ ;; time (Binutils, bzip2, file, etc.)
+ (string-append "-Dlibpth=" libc "/lib")
+ (string-append "-Dplibpth=" libc "/lib"))))))
(add-before
'strip 'make-shared-objects-writable