summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2017-08-09 19:00:32 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-14 11:45:56 +0200
commit413dd21084ea96067a8f25d23fd0d01088f55e67 (patch)
tree65fbfee0c0ef3cc7221b781ec9b1ad8773e3529c /gnu/packages/perl.scm
parent649238cbc75968e0c093deef88ab3ca31161d258 (diff)
gnu: Add perl-type-tie.
* gnu/packages/perl.scm (perl-type-tie): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index dcd9640d92..5c36cedc76 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7726,6 +7726,34 @@ that are designed to minimize common mistakes with eval blocks, and nothing
else.")
(license x11)))
+(define-public perl-type-tie
+ (package
+ (name "perl-type-tie")
+ (version "0.009")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/T/TO/TOBYINK/"
+ "Type-Tie-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1wv32kd7gx4kfyvzs13y029f49qbbji991wawvarac7rlz09wpan"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-fatal" ,perl-test-fatal)
+ ("perl-test-requires" ,perl-test-requires)))
+ (propagated-inputs
+ `(("perl-exporter-tiny" ,perl-exporter-tiny)
+ ("perl-hash-fieldhash" ,perl-hash-fieldhash)))
+ (home-page "http://search.cpan.org/dist/Type-Tie")
+ (synopsis "Tie a variable to a type constraint")
+ (description "This module exports a single function: @code{ttie}. It ties
+a variable to a type constraint, ensuring that whatever values stored in the
+variable will conform to the type constraint. If the type constraint has
+coercions, these will be used if necessary to ensure values assigned to the
+variable conform.")
+ (license (package-license perl))))
+
(define-public perl-types-serialiser
(package
(name "perl-types-serialiser")