summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-28 20:54:18 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-12 22:59:37 +0100
commitd6daca0ee50bfe3be894ea964b689915ecf1cb21 (patch)
tree693587df745fb93a5510fbaa5cab608825eb52ac /gnu/packages/perl.scm
parent2d6125ed4d210e4612231683e696e69d9cc9cc40 (diff)
gnu: Add perl-mailtools.
* gnu/packages/perl.scm (perl-mailtools): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 90b9a6f8a1..e2aa33f291 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -4205,6 +4205,51 @@ implementation of these functions only serves as a fallback in case the C
portions of this module couldn't be compiled on this machine.")
(license (package-license perl))))
+(define-public perl-mailtools
+ (package
+ (name "perl-mailtools")
+ (version "2.19")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MA/MARKOV/MailTools-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "06jykkv8mp484vzkmwd6dkicx029rl3ir5ljzrbap3paxw1dfzn1"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-timedate" ,perl-timedate)))
+ (home-page
+ "http://search.cpan.org/dist/MailTools")
+ (synopsis "Bundle of ancient email modules")
+ (description "MailTools contains the following modules:
+@table @asis
+@item Mail::Address
+Parse email address from a header line.
+@item Mail::Cap
+Interpret mailcap files: mappings of file-types to applications as used by
+many command-line email programs.
+@item Mail::Field
+Simplifies access to (some) email header fields. Used by Mail::Header.
+@item Mail::Filter
+Process Mail::Internet messages.
+@item Mail::Header
+Collection of Mail::Field objects, representing the header of a Mail::Internet
+object.
+@item Mail::Internet
+Represents a single email message, with header and body.
+@item Mail::Mailer
+Send Mail::Internet emails via direct smtp or local MTA's.
+@item Mail::Send
+Build a Mail::Internet object, and then send it out using Mail::Mailer.
+@item Mail::Util
+\"Smart functions\" you should not depend on.
+@end table")
+ (license perl-license)))
+
(define-public perl-memoize-expirelru
(package
(name "perl-memoize-expirelru")