summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-22 14:08:41 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 10:10:39 +0100
commit55932aeee13827b2df0d0729ee857e422e990a98 (patch)
tree0dbbd0c84d15cc3f10464f86fa7db3ed9b0bc4a2 /gnu/packages/perl.scm
parent8f1640ed8f0fa8d917116cd4b85c47be34b121d4 (diff)
gnu: Add MIME::Charset.
* gnu/packages/perl.scm (perl-mime-charset): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 95aa596cf5..4abd9972fe 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2839,6 +2839,25 @@ follows LRU semantics, that is, the last n results, where n is specified as
the argument to the CACHESIZE parameter, will be cached.")
(license (package-license perl))))
+(define-public perl-mime-charset
+ (package
+ (name "perl-mime-charset")
+ (version "1.012")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/N/NE/NEZUMI/"
+ "MIME-Charset-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1kfc5p4g1x9c0ffhg125wvhravcviny3alwrgnhnrm2a33ad3rff"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/MIME-Charset")
+ (synopsis "Charset information for MIME messages")
+ (description
+ "@code{MIME::Charset} provides information about character sets used for
+MIME messages on Internet.")
+ (license (package-license perl))))
+
(define-public perl-mime-types
(package
(name "perl-mime-types")