summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2016-01-20 17:12:53 -0600
committerEric Bavier <bavier@member.fsf.org>2016-01-20 17:45:31 -0600
commit97b07aaa419bfa069bb217fca2f158f6ea0804a1 (patch)
tree6728209273d2f4186edec642bf8830dbb79c4afc /gnu/packages/perl.scm
parent7b158c4ee2d4b5cf6a2cd9bf0246465c3c8a06ca (diff)
gnu: Add perl-module-pluggable.
This Perl module was moved out of Perl core in v5.19.0. * gnu/packages/perl.scm (perl-module-pluggable): New variable. * gnu/packages/patches/perl-module-pluggable-search.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 51fb96516a..4d9806cf4b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
;;;
@@ -3077,6 +3077,26 @@ strictly correct manner with ExtUtils::MakeMaker, and will run on any Perl
installation version 5.005 or newer.")
(license (package-license perl))))
+(define-public perl-module-pluggable
+ (package
+ (name "perl-module-pluggable")
+ (version "5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SI/SIMONW/"
+ "Module-Pluggable-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1px6qmszmfc69v36vd8d92av4nkrif6xf4nrj3xv647xwi2svwmk"))
+ (patches (list (search-patch "perl-module-pluggable-search.patch")))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Module-Pluggable")
+ (synopsis "Give your Perl module the ability to have plugins")
+ (description "This module provides a simple but extensible way of having
+'plugins' for your Perl module.")
+ (license (package-license perl))))
+
(define-public perl-module-runtime
(package
(name "perl-module-runtime")