summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-11-23 22:10:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-27 09:48:42 +0100
commitdc32ee53810c830c2ecf866e0a9ef182ec6b5f3d (patch)
treeff4bf8ca5ebea3cc413c28c392ed834c0345fa7c /gnu/packages/perl.scm
parent44c31aaae8b7ba021c0144dead0ccb4fee929d10 (diff)
gnu: Add perl-text-roman.
* gnu/packages/perl.scm (perl-text-roman): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 42514d1a1e..9ed0f05240 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6861,6 +6861,27 @@ template engine, for when you need speed rather than complex features,
yet need more features than simple variable substitution.")
(license (package-license perl))))
+(define-public perl-text-roman
+ (package
+ (name "perl-text-roman")
+ (version "3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/S/SY/SYP/Text-Roman-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0sh47svzz0wm993ywfgpn0fvhajl2sj5hcnf5zxjz02in6ihhjnb"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Text-Roman")
+ (synopsis "Convert between Roman and Arabic algorisms")
+ (description "This package provides functions to convert between Roman and
+Arabic algorisms. It supports both conventional Roman algorisms (which range
+from 1 to 3999) and Milhar Romans, a variation which uses a bar across the
+algorism to indicate multiplication by 1000.")
+ (license (package-license perl))))
+
(define-public perl-text-simpletable
(package
(name "perl-text-simpletable")