summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2016-07-12 15:07:59 +1000
committerBen Woodcroft <donttrustben@gmail.com>2016-08-08 22:08:17 +1000
commit176345c5b2455a7c9e31996fcc9b505fe1fe4e6e (patch)
tree0949254c765b2b3fcea1435cfdf3b8e3d18d2d4e /gnu/packages/perl.scm
parent47bc991f71d0314217d103798db99f55ce59cde5 (diff)
gnu: Add perl-xml-writer.
* gnu/packages/perl.scm (perl-xml-writer): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4423c77bbd..032ea5e439 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -10,6 +10,7 @@
;;; Coypright © 2016 ng0 <ng0@we.make.ritual.n0.is>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
;;; Copyright © 2016 Roel Janssen <roel@gnu.org>
+;;; Copyright © 2016 Ben Woodcroft <donttrustben@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -6514,6 +6515,33 @@ it. With this module, you can add your own magic to any variable without
having to write a single line of XS.")
(license (package-license perl))))
+(define-public perl-xml-writer
+ (package
+ (name "perl-xml-writer")
+ (version "0.625")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/J/JO/JOSEPHW/XML-Writer-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1gjzs570i67ywbv967g8ylb5sg59clwmyrl2yix3jl70dhn55070"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/XML-Writer")
+ (synopsis "Easily generate well-formed, namespace-aware XML")
+ (description "@code{XML::Writer} is a simple Perl module for writing XML
+documents: it takes care of constructing markup and escaping data correctly.
+By default, it also performs a significant amount of well-formedness checking
+on the output to make certain (for example) that start and end tags match,
+that there is exactly one document element, and that there are not duplicate
+attribute names.")
+ ;; Redistribution and use in source and compiled forms, with or without
+ ;; modification, are permitted under any circumstances. No warranty.
+ (license public-domain)))
+
(define-public perl-yaml
(package
(name "perl-yaml")