summaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:18:00 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 10:41:57 +0200
commit479fedb025431598aad049f169ceba0ee8b1fdb9 (patch)
tree6d041a6a9fde343ac8d44198f1b509aad62b5ba7 /gnu/packages/perl6.scm
parent90a7efcc1e618ff21e100a4041ba32d541f2bd5f (diff)
gnu: perl6-terminal-ansicolor: Perl -> Raku.
* gnu/packages/perl6.scm (perl6-terminal-ansicolor): Extract commit outside of source. [description]: Replace mention of Perl with Raku. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm38
1 files changed, 19 insertions, 19 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index d18d953d5a..408d7e8e97 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -707,26 +707,26 @@ minimal wrapper around an instance of this module.")
(license license:artistic2.0)))
(define-public perl6-terminal-ansicolor
- (package
- (name "perl6-terminal-ansicolor")
- (version "0.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
+ ;; The commit where 0.5 was “tagged”.
+ (let ((commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212"))
+ (package
+ (name "perl6-terminal-ansicolor")
+ (version "0.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
(url "https://github.com/tadzik/Terminal-ANSIColor")
- ;; The commit where 0.5 was "tagged"
- (commit "edded4a7116ce11cbc9fb5a83669c7ba119d0212")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
- (build-system rakudo-build-system)
- (arguments '(#:with-zef? #f))
- (home-page "https://github.com/tadzik/Terminal-ANSIColor")
- (synopsis "Colorize terminal output")
- (description "This is a @code{Terminal::ANSIColor} module for Perl 6.")
- (license license:expat)))
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1apm999azkyg5s35gid12wq019aqnvzrkz7qjmipd74mdxgr00x7"))))
+ (build-system rakudo-build-system)
+ (arguments '(#:with-zef? #f))
+ (home-page "https://github.com/tadzik/Terminal-ANSIColor")
+ (synopsis "Colorize terminal output")
+ (description "This is a @code{Terminal::ANSIColor} module for Raku.")
+ (license license:expat))))
(define-public perl6-test-meta
(package