summaryrefslogtreecommitdiff
path: root/gnu/packages/perl6.scm
diff options
context:
space:
mode:
authorPaul A. Patience <paul@apatience.com>2022-04-29 05:17:17 +0000
committerEfraim Flashner <efraim@flashner.co.il>2024-03-04 09:21:55 +0200
commitd154fa0bae0a4e6ee1684dac42a04b1b36ce544b (patch)
treee4dc39b80a6f6f551b606e99a166d42d92707911 /gnu/packages/perl6.scm
parent3e1e1316107ecffaae56c8ed3229a66a7c13bd6f (diff)
gnu: rakudo: Remove trailing booleans.
* gnu/packages/perl6.scm (rakudo)[source]: Reindent. [arguments]: Remove trailing booleans. Reindent. [native-search-paths]: Reindent. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/perl6.scm')
-rw-r--r--gnu/packages/perl6.scm37
1 files changed, 17 insertions, 20 deletions
diff --git a/gnu/packages/perl6.scm b/gnu/packages/perl6.scm
index 5f807a1743..052d4e0914 100644
--- a/gnu/packages/perl6.scm
+++ b/gnu/packages/perl6.scm
@@ -161,13 +161,13 @@ regular expression engine for the virtual machine.")
(name "rakudo")
(version "2019.03.1")
(source
- (origin
- (method url-fetch)
- (uri (string-append "https://rakudo.perl6.org/downloads/rakudo/rakudo-"
- version ".tar.gz"))
- (sha256
- (base32
- "1nllf69v8xr6v3kkj7pmryg11n5m3ajfkr7j72pvhrgnjy8lv3r1"))))
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://rakudo.perl6.org/downloads/rakudo/rakudo-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1nllf69v8xr6v3kkj7pmryg11n5m3ajfkr7j72pvhrgnjy8lv3r1"))))
(build-system perl-build-system)
(arguments
'(#:phases
@@ -175,16 +175,14 @@ regular expression engine for the virtual machine.")
(add-after 'unpack 'patch-source-date
(lambda _
(substitute* "tools/build/gen-version.pl"
- (("gmtime") "gmtime(0)"))
- #t))
+ (("gmtime") "gmtime(0)"))))
(add-after 'patch-source-shebangs 'patch-more-shebangs
(lambda _
(substitute* '("tools/build/create-js-runner.pl"
"tools/build/create-moar-runner.p6"
"tools/build/create-jvm-runner.pl"
"src/core/Proc.pm6")
- (("/bin/sh") (which "sh")))
- #t))
+ (("/bin/sh") (which "sh")))))
(replace 'configure
(lambda* (#:key inputs outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out"))
@@ -197,23 +195,22 @@ regular expression engine for the virtual machine.")
;; modules systemwide. See: https://github.com/ugexe/zef/issues/117
(add-after 'install 'install-dist-tool
(lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
+ (let* ((out (assoc-ref outputs "out"))
(dest (string-append out "/share/perl6/tools")))
(install-file "tools/install-dist.p6" dest)
(substitute* (string-append dest "/install-dist.p6")
(("/usr/bin/env perl6")
- (string-append out "/bin/perl6"))))
- #t)))))
+ (string-append out "/bin/perl6")))))))))
(inputs
(list moarvm nqp openssl))
(home-page "https://rakudo.org/")
(native-search-paths
- (list (search-path-specification
- (variable "PERL6LIB")
- (separator ",")
- (files '("share/perl6/lib"
- "share/perl6/site/lib"
- "share/perl6/vendor/lib")))))
+ (list (search-path-specification
+ (variable "PERL6LIB")
+ (separator ",")
+ (files '("share/perl6/lib"
+ "share/perl6/site/lib"
+ "share/perl6/vendor/lib")))))
(synopsis "Perl 6 Compiler")
(description "Rakudo Perl is a compiler that implements the Perl 6
specification and runs on top of several virtual machines.")