summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2022-10-17 00:07:23 -0400
committerChristopher Baines <mail@cbaines.net>2022-10-22 10:24:22 +0100
commit95ffc456462f440a006ca446f29f43524179a6b8 (patch)
treec1171793508c04c3c479d3f63ce20caaaf304e6d /gnu/packages/photo.scm
parentc2b263fcb75fa0ddf82a5217a83f76b021f55e7b (diff)
gnu: darktable: Update to 4.0.1.
* gnu/packages/photo.scm (darktable): Update to 4.0.1. [phases]{fix-missing-include}: New phase to work around an upstream bug of a missing include statement. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 378f60793f..e819b5312d 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -460,7 +460,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "4.0.0")
+ (version "4.0.1")
(source
(origin
(method url-fetch)
@@ -468,7 +468,7 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "0bfcag6bj5vcmg4z4xjirs43iafcx89al6jl41i5mrhpjzszh5hl"))))
+ (base32 "0s0xwp5n4jhzdhbmsg02dlsc503jfznpwqn3rnipg687q3h83vsz"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
@@ -482,6 +482,13 @@ photographic equipment.")
(("\"libOpenCL\"")
(string-append "\"" (assoc-ref inputs "opencl-icd-loader")
"/lib/libOpenCL.so\"")))))
+ (add-after 'unpack 'fix-missing-include
+ (lambda _
+ ;; Fix missing include needed to build tests. See upstream
+ ;; issue: https://github.com/darktable-org/darktable/issues/12604
+ (substitute* "./src/common/variables.h"
+ (("once")
+ "once\n#include \"common/image.h\""))))
(add-before 'configure 'prepare-build-environment
(lambda* (#:key inputs #:allow-other-keys)
;; Rawspeed fails to build with GCC due to OpenMP error: