summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2023-12-08 15:36:18 -0300
committerVinicius Monego <monego@posteo.net>2024-01-19 22:01:30 -0300
commite7d14578ad38eae78aafdccdf0bfe457b1db2e10 (patch)
treebd045b16f2cab6ef755f304d818b2fa157bc70e9 /gnu/packages/photo.scm
parent50731875243428cb11cc17fa712fa8079b307622 (diff)
gnu: darktable: Build with GCC.
* gnu/packages/photo.scm (darktable)[arguments][#:phases]: Delete the 'prepare-build-environment phase. [native-inputs]: Remove clang. Add gcc-13. Change-Id: Ia0dc1c6a717ccd00cd31d378aa51ce63fbf1806a
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index c1ff860c43..de5423c92e 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2020 Sebastian Schott <sschott@mailbox.org>
;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
-;;; Copyright © 2020. 2021, 2022 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020. 2021, 2022, 2024 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2022, 2023 John Kehayias <john.kehayias@protonmail.com>
;;; Copyright © 2022 Sharlatan Hellseher <sharlatanus@gmail.com>
;;; Copyright © 2023 Bruno Victal <mirai@makinata.eu>
@@ -54,6 +54,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages file)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages geo)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
@@ -553,17 +554,6 @@ photographic equipment.")
(string-append "\""
(search-input-file inputs "/lib/libOpenCL.so")
"\"")))))
- (add-before 'configure 'prepare-build-environment
- (lambda _
- ;; Rawspeed fails to build with GCC due to OpenMP error:
- ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
- (setenv "CC" "clang")
- (setenv "CXX" "clang++")
- ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
- ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
- (substitute* "CMakeLists.txt"
- (("\\$\\{LLVM_INSTALL_PREFIX\\}")
- #$(this-package-native-input "clang")))))
(add-before 'configure 'set-LDFLAGS
(lambda _
(setenv "LDFLAGS"
@@ -576,13 +566,13 @@ photographic equipment.")
(,(string-append #$(this-package-input "gtk+")
"/share/glib-2.0/schemas")))))))))
(native-inputs
- (list clang
- cmocka
+ (list cmocka
desktop-file-utils
+ gcc-13 ; gcc-11 too old for darktable, 12+ required
`(,glib "bin")
gobject-introspection
intltool
- llvm ;should match the Clang version
+ llvm
opencl-headers
perl
pkg-config