summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-09-16 17:49:27 +0100
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-09-17 16:22:04 -0400
commit8202adbceeba6c43dd5af5ffaa35e780cc9c5429 (patch)
tree2946d095c552b98ec2384194fc1b3b438823cf50 /gnu/packages/photo.scm
parenta6170fcd2ba1b4b677399f048bdcd7a5701775af (diff)
gnu: enblend-enfuse: Backport upstream fixes.
Backport changes for reproducible builds & missing include. * gnu/packages/patches/enblend-enfuse-reproducible.patch: New file. * gnu/local.mk: Register it. * gnu/packages/photo.scm (enblend-enfuse)[source]: Use newly added patch. Add snippet to fix missing header. [arguments]<#:phases>: Remove 'add-missing-include. Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index b290e2b29a..39f4ce10d6 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -370,7 +370,18 @@ overlapping images, as well as some command line tools.")
name "-" version ".tar.gz"))
(sha256
(base32
- "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))))
+ "0j5x011ilalb47ssah50ag0a4phgh1b0wdgxdbbp1gcyjcjf60w7"))
+ (patches
+ ;; TODO: Remove when updating.
+ ;; Fixed upstream with a98e00eed893f62dd8349fc2894abca3aff4b33a.
+ (search-patches "enblend-enfuse-reproducible.patch"))
+ (modules '((guix build utils)))
+ (snippet
+ ;; TODO: Remove when updating.
+ ;; Fixed upstream with 81e25afe71146aaaf5058c604034f35d57e3be9d.
+ #~(substitute* "src/minimizer.cc"
+ (("^#include <gsl/gsl_errno\\.h>" all)
+ (string-append all "\n#include <limits>"))))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config
@@ -395,16 +406,8 @@ overlapping images, as well as some command line tools.")
vigra
zlib))
(arguments
- (list #:configure-flags
- #~(list "--enable-openmp")
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'add-missing-include
- (lambda _
- (substitute* "src/minimizer.h"
- ;; Fix error: ‘numeric_limits’ is not a member of ‘std’.
- (("#include <vector>" line)
- (string-append line "\n#include <limits>"))))))))
+ (list
+ #:configure-flags #~(list "--enable-openmp")))
(home-page "https://enblend.sourceforge.net/")
(synopsis "Tools for combining and blending images")
(description