summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-24 19:56:35 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-24 19:56:35 +0200
commit706ae8e15c8d36b0aee7c19c54c143d3e17f5784 (patch)
treee9fe8ebfb1417d30979b5413165599f066a1c504 /gnu/packages/php.scm
parent3e95125e9bd0676d4a9add9105217ad3eaef3ff0 (diff)
parent8440db459a10daa24282038f35bc0b6771bd51ab (diff)
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm14
1 files changed, 10 insertions, 4 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 90e6ab1c1c..121ffab767 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -62,7 +62,7 @@
(define-public php
(package
(name "php")
- (version "7.2.4")
+ (version "7.2.8")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -70,7 +70,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "123s0lbyz4fxr3kk91r4v658mk899dym36lggxnx9pwd2jyv25kr"))
+ "03zv1y8ygzsir60617hinpji3f4irk79zbp3ar1b8zcapq40gfjk"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -248,6 +248,9 @@
;; iconv breaks the loop after the first error with Termsig=11.
"ext/iconv/tests/iconv_strpos_variation4.phpt"
"ext/iconv/tests/iconv_strrpos_variation3.phpt"
+ ;; Expects "invalid multibyte sequence" but got
+ ;; "unknown error".
+ "ext/iconv/tests/bug76249.phpt"
;; XXX: These test failures appear legitimate, needs investigation.
;; open_basedir() restriction failure.
@@ -288,7 +291,10 @@
"ext/mbstring/tests/mb_ereg_variation3.phpt"
"ext/mbstring/tests/mb_ereg_replace_variation1.phpt"
"ext/mbstring/tests/bug72994.phpt"
- "ext/ldap/tests/ldap_set_option_error.phpt"))
+ "ext/ldap/tests/ldap_set_option_error.phpt"
+
+ ;; Sometimes cannot start the LDAP server.
+ "ext/ldap/tests/bug76248.phpt"))
;; Skip tests requiring network access.
(setenv "SKIP_ONLINE_TESTS" "1")
@@ -318,7 +324,7 @@
("libxpm" ,libxpm)
("libxslt" ,libxslt)
("libx11" ,libx11)
- ("oniguruma" ,oniguruma)
+ ("oniguruma" ,oniguruma-5)
("openldap" ,openldap)
("openssl" ,openssl)
("pcre" ,pcre)