summaryrefslogtreecommitdiff
path: root/gnu/packages/plan9.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 00:07:06 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-31 11:32:37 -0500
commitce02c5b5de3492864e180ce785c07772e174f2da (patch)
tree7f7132c277a078dfaac19f95a0c6649ff4d7cc91 /gnu/packages/plan9.scm
parent6573a72cdadebdf802ec7383253e44b975833895 (diff)
gnu: Do not eagerly load (gnu packages commencement).
As its top comment says, this module is not meant to be imported to avoid circular module dependencies. * gnu/packages/chicken.scm (chicken) [propagated-inputs]: Resolve gcc-toolchain lazily. * gnu/packages/plan9.scm (plan9port): Likewise. * gnu/packages/raspberry-pi.scm (raspi-arm64-chainloader) [native-inputs]: Resolve ld-wrapper lazily. Change-Id: Ie9859046ed32b67dc53bcc5444d6ae162e5d4022
Diffstat (limited to 'gnu/packages/plan9.scm')
-rw-r--r--gnu/packages/plan9.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/plan9.scm b/gnu/packages/plan9.scm
index b2d8d75471..801146370c 100644
--- a/gnu/packages/plan9.scm
+++ b/gnu/packages/plan9.scm
@@ -26,7 +26,6 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
- #:use-module (gnu packages commencement)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages perl)
#:use-module (gnu packages xorg))
@@ -162,7 +161,9 @@ reconstruct a Plan 9 terminal-like experience from a non-Plan 9 system.")
fontconfig libx11 libxext libxt))
;; Propagate gcc-toolchain because some programs, like the 9c compiler,
;; are just aliased scripts to gcc equivalents.
- (propagated-inputs (list gcc-toolchain))
+ (propagated-inputs (list (module-ref (resolve-interface
+ '(gnu packages commencement))
+ 'gcc-toolchain)))
(home-page "https://9fans.github.io/plan9port/")
(synopsis "Port of many Plan 9 libraries and programs")
(description