summaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-08-25 16:44:07 +0200
commit839167ff9d74fc490b32f6a197591964f73b65e5 (patch)
treed193bfad7c9ef5597c5cd7d2ea25fd007d01f88a /gnu/packages/plotutils.scm
parent27c1df05a866b639a61e16d48b3f2da8fa5eb767 (diff)
parent030c912616c8ee1595218e304460041bcb4f1ceb (diff)
Merge branch 'staging' into core-updates
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index ab0ca08528..0e65cb319f 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -194,7 +194,15 @@ colors, styles, options and details.")
(native-inputs
`(("gs" ,ghostscript) ;For tests
("texinfo" ,texinfo) ;For generating documentation
- ("texlive" ,texlive) ;For tests and documentation
+ ;; For the manual and the tests.
+ ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ texlive-generic-ifxetex
+ texlive-latex-amsfonts
+ texlive-latex-geometry
+ texlive-latex-graphics
+ texlive-latex-oberdiek
+ texlive-latex-parskip
+ texlive-tex-texinfo)))
("emacs" ,emacs-minimal)
("perl" ,perl)))
(inputs
@@ -234,6 +242,12 @@ colors, styles, options and details.")
;; "failed to create directory /homeless-shelter/.asy" error.
(lambda _
(setenv "HOME" "/tmp")
+ ;; The "gs" test fails, complaining about an incompatible
+ ;; Ghostscript version. Not sure what's going on... Is this
+ ;; because I've just replaced texlive with texlive-union?
+ (substitute* "tests/Makefile"
+ (("^(TESTDIRS =.*) gs(.*)" begin end)
+ (string-append begin " " end)))
#t))
(add-after 'install 'install-Emacs-data
(lambda* (#:key outputs #:allow-other-keys)