summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2022-11-14 08:59:23 +0000
committerChristopher Baines <mail@cbaines.net>2022-11-14 08:59:23 +0000
commitf73d9690ad692653548457d4ab108b5200ef4d9b (patch)
tree58ab173bc46e3f5814288b499e45ef8f94e68965 /gnu/packages/protobuf.scm
parent775134ebf537895bcb7bf2a6c541846845403737 (diff)
gnu: protobuf-2: Use gexp in arguments.
This fixes the breakage introduced when the protobuf package switched to using gexp's in the arguments. The package doesn't build, but at least the builder is now deterministic and valid Guile. * gnu/packages/protobuf.scm (protobuf-2)[arguments]: Adapt to use gexp's.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 22900e89cd..eda1b5ec51 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -214,8 +214,8 @@ internal RPC protocols and file formats.")
"040rcs9fpv4bslhiy43v7dcrzakz4vwwpyqg4jp8bn24sl95ci7f"))))
(arguments (substitute-keyword-arguments (package-arguments protobuf)
((#:phases phases)
- `(modify-phases ,phases
- (delete 'disable-broken-tests)))))))
+ #~(modify-phases #$phases
+ (delete 'disable-broken-tests)))))))
(define-public protobuf-c
(package