summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-11-16 09:34:27 +0100
commit154d97abdd16674fdebc763351f661bbcdc869a4 (patch)
tree0277a9380edd1390f16e432283d32499ffed36d1 /gnu/packages/protobuf.scm
parente4696c69d75f4fcf54c42beeb928032726bdaf7d (diff)
parent87e7faa2ae641d8302efc8b90f1e45f43f67f6da (diff)
Merge remote-tracking branch master into core-updates
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm41
1 files changed, 28 insertions, 13 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index b30461e153..d00057934d 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2016 Daniel Pimentel <d4n1@d4n1.org>
;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -75,7 +75,7 @@ data in motion, or as a file format for data at rest.")
(define-public protobuf
(package
(name "protobuf")
- (version "3.5.1")
+ (version "3.10.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/google/protobuf/releases/"
@@ -83,7 +83,7 @@ data in motion, or as a file format for data at rest.")
version ".tar.gz"))
(sha256
(base32
- "14j0427ykjzrd9a66c2mpk0sjcccjlsx6q8ww6hzwb6sha3vm3f2"))))
+ "16xrclp3xw4hzni1h53px9s99657hs5790726lchm3hrvsyyabp8"))))
(build-system gnu-build-system)
(inputs `(("zlib" ,zlib)))
(outputs (list "out"
@@ -112,9 +112,9 @@ yet extensible format. Google uses Protocol Buffers for almost all of its
internal RPC protocols and file formats.")
(license license:bsd-3)))
-(define-public protobuf-next
- (package (inherit protobuf)
- (name "protobuf")
+;; Tensorflow requires version 3.6 specifically.
+(define-public protobuf-3.6
+ (package/inherit protobuf
(version "3.6.1")
(source (origin
(method url-fetch)
@@ -125,6 +125,20 @@ internal RPC protocols and file formats.")
(base32
"0a955bz59ihrb5wg7dwi12xajdi5pmz4bl0g147rbdwv393jwwxk"))))))
+;; The 3.5 series are the last versions that do not require C++ 11.
+(define-public protobuf-3.5
+ (package/inherit
+ protobuf
+ (version "3.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/google/protobuf/releases/"
+ "download/v" version "/protobuf-cpp-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "14j0427ykjzrd9a66c2mpk0sjcccjlsx6q8ww6hzwb6sha3vm3f2"))))))
+
;; XXX Remove this old version when no other packages depend on it.
(define-public protobuf-2
(package (inherit protobuf)
@@ -141,7 +155,7 @@ internal RPC protocols and file formats.")
(define-public protobuf-c
(package
(name "protobuf-c")
- (version "1.3.1")
+ (version "1.3.2")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/protobuf-c/protobuf-c/"
@@ -149,7 +163,7 @@ internal RPC protocols and file formats.")
"/protobuf-c-" version ".tar.gz"))
(sha256
(base32
- "0rr2kn7804cvhdm6lzz04gz76vy0fzj15dijbr17nv8x34x2sisi"))))
+ "0x4ybd9rfd878p2imz0hb8zxfd7l60vbdw7cg84dnysr9kqm3wjk"))))
(build-system gnu-build-system)
(inputs `(("protobuf" ,protobuf)))
(native-inputs `(("pkg-config" ,pkg-config)))
@@ -189,14 +203,14 @@ encoder in C++. The developer using protozero has to manually translate the
(define-public python-protobuf
(package
(name "python-protobuf")
- (version "3.5.2")
+ (version "3.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "protobuf" version))
(sha256
(base32
- "1q4b1m55w4gvcbzklbk8iylaii98n4in41k27d94w8ypbwlrm1q9"))))
+ "1zjq3qi0wgqi0fwxgqlgwvj9ri1m4kmnz3jnpd803lqc5k0vb0yv"))))
(build-system python-build-system)
(propagated-inputs
`(("python-six" ,python-six)))
@@ -210,10 +224,11 @@ mechanism for serializing structured data.")
(define-public python2-protobuf
(package-with-python2 python-protobuf))
-(define-public python-protobuf-next
- (package (inherit python-protobuf)
+;; For tensorflow.
+(define-public python-protobuf-3.6
+ (package/inherit python-protobuf
(name "python-protobuf")
- (version (package-version protobuf-next) )
+ (version (package-version protobuf-3.6) )
(source
(origin
(method url-fetch)