summaryrefslogtreecommitdiff
path: root/gnu/packages/protobuf.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-11-11 17:19:10 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-11-11 17:19:10 +0100
commitac07544ebffc722afd092d24feeba69e5a1c68d1 (patch)
treef81d2d184fbf58da0594c6eed0c8fae8375d73d7 /gnu/packages/protobuf.scm
parentd4ec49d1dab952478501349b9eace0f7f7dfaecd (diff)
gnu: Add protobuf-c-for-aiscm.
* gnu/packages/protobuf.scm (protobuf-c-for-aiscm): New variable.
Diffstat (limited to 'gnu/packages/protobuf.scm')
-rw-r--r--gnu/packages/protobuf.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index 1448691a42..22900e89cd 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -242,6 +242,20 @@ generator that converts Protocol Buffer @code{.proto} files to C descriptor
code.")
(license license:bsd-2)))
+(define-public protobuf-c-for-aiscm
+ (package
+ (inherit protobuf-c)
+ (version "1.3.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/protobuf-c/protobuf-c/"
+ "releases/download/v" version
+ "/protobuf-c-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0y3yaanq97si7iyld06p8w20m0shpj7sf4xwzbhhvijhxw36d592"))))
+ (inputs (list protobuf-3.6))))
+
(define-public protozero
(package
(name "protozero")