summaryrefslogtreecommitdiff
path: root/gnu/packages/psyc.scm
diff options
context:
space:
mode:
authorng0 <ngillmann@runbox.com>2016-10-04 08:34:27 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-10-23 16:32:03 +0300
commit5cb79741096f30791851dbb040284c1e11c32b76 (patch)
tree0a634191364c166cea25b268f4b28e49fee8b69c /gnu/packages/psyc.scm
parent3a14b2bcf61589f65aa2694b5474d79e9b571db5 (diff)
gnu: Add libpsyc.
* gnu/packages/psyc.scm (libpsyc): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/psyc.scm')
-rw-r--r--gnu/packages/psyc.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/psyc.scm b/gnu/packages/psyc.scm
index f2f661eb77..57042946d5 100644
--- a/gnu/packages/psyc.scm
+++ b/gnu/packages/psyc.scm
@@ -21,7 +21,10 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix build-system perl)
+ #:use-module (guix build-system gnu)
#:use-module (gnu packages)
+ #:use-module (gnu packages admin)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages perl)
#:use-module (gnu packages web))
@@ -104,3 +107,39 @@ for @uref{https://torproject.org,tor} router) and many more.")
license:public-domain
;; bin/psycplay states AGPL with no version:
license:agpl3+))))
+
+(define-public libpsyc
+ (package
+ (name "libpsyc")
+ (version "20160913")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://www.psyced.org/files/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "14q89fxap05ajkfn20rnhc6b1h4i3i2adyr7y6hs5zqwb2lcmc1p"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("netcat" ,netcat)
+ ("procps" ,procps)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; The rust bindings are the only ones in use, the lpc bindings
+ ;; are in psyclpc. The other bindings are not used by anything,
+ ;; the chances are high that the bindings do not even work,
+ ;; therefore we do not include them.
+ ;; TODO: Get a cargo build system in Guix.
+ (delete 'configure)))) ; no configure script
+ (home-page "http://about.psyc.eu/libpsyc")
+ (description
+ "@code{libpsyc} is a PSYC library in C which implements
+core aspects of PSYC, useful for all kinds of clients and servers
+including psyced.")
+ (synopsis "PSYC library in C")
+ (license license:agpl3+)))