summaryrefslogtreecommitdiff
path: root/gnu/packages/purescript.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:01 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2023-07-16 02:00:07 +0200
commitbf767b2907df62e446cc26e599c30e7e6e11b86d (patch)
treebd89489ace7bc80880c4e64d4e623ea1ffd825b8 /gnu/packages/purescript.scm
parent1d8220216ec5998d5fd001f037d7cffcb8d6003f (diff)
gnu: purescript: Use G-expressions.
* gnu/packages/purescript.scm (purescript)[arguments]: Rewrite as G-expressions.
Diffstat (limited to 'gnu/packages/purescript.scm')
-rw-r--r--gnu/packages/purescript.scm15
1 files changed, 9 insertions, 6 deletions
diff --git a/gnu/packages/purescript.scm b/gnu/packages/purescript.scm
index 75633895e6..ef58ecbf82 100644
--- a/gnu/packages/purescript.scm
+++ b/gnu/packages/purescript.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages haskell-web)
#:use-module ((gnu packages python) #:select (python))
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix packages)
#:use-module (guix build-system haskell)
@@ -96,21 +97,23 @@
ghc-typed-process
ghc-happy))
(arguments
- `(;; Tests require npm
- #:tests? #f
- #:configure-flags '("--flags=release")
+ (list
+ ;; Tests require npm
+ #:tests? #f
+ #:configure-flags
+ #~(list "--flags=release")
#:haddock? #f
#:phases
- (modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(add-before 'configure 'update-constraints
(lambda _
(substitute* "purescript.cabal"
(("\\b(language-javascript|process)\\s+[^,]+" all dep)
dep))))
(add-after 'register 'remove-libraries
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
(delete-file-recursively
- (string-append (assoc-ref outputs "out") "/lib")))))))
+ (string-append #$output "/lib")))))))
(home-page "https://www.purescript.org/")
(synopsis "Haskell inspired programming language compiling to JavaScript")
(description