summaryrefslogtreecommitdiff
path: root/gnu/packages/python-build.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-16 23:43:09 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-04-19 20:12:16 -0400
commit96be62d2ed521942fa7f19ac42b9129eb5a6e918 (patch)
treee1b50895a27cb3c2a1bc5cf47fc8fbe3f46033d8 /gnu/packages/python-build.scm
parentffef022d652e4a27c7629c38bb90b5a206d3f0fc (diff)
gnu: python-typing-extensions: Update to 4.5.0.
* gnu/packages/python-build.scm (python-typing-extensions): Update to 4.5.0. [home-page]: Update URL.
Diffstat (limited to 'gnu/packages/python-build.scm')
-rw-r--r--gnu/packages/python-build.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 0e3d3675a4..c5185a77fb 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -216,19 +216,19 @@ PyPI (pypi.org).")
(define-public python-typing-extensions
(package
(name "python-typing-extensions")
- (version "4.3.0")
+ (version "4.5.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "typing_extensions" version))
(sha256
(base32
- "19n4l57qazwrbvxjrbxw2vvfyd0zbk8ivnwm4zmwfzzl69x6glp6"))))
+ "1jx7ki3sji60v7h2805b2phq9ynsvshj5xiygdh9kmirj6kz9daw"))))
(build-system pyproject-build-system)
;; Disable the test suite to keep the dependencies to a minimum. Also,
;; the test suite requires Python's test module, not available in Guix.
(arguments (list #:tests? #f))
(native-inputs (list python-flit-core))
- (home-page "https://github.com/python/typing/typing_extensions")
+ (home-page "https://github.com/python/typing_extensions")
(synopsis "Experimental type hints for Python")
(description
"The typing_extensions module contains additional @code{typing} hints not