summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2022-11-28 23:34:25 -0600
committerEfraim Flashner <efraim@flashner.co.il>2022-11-29 08:38:29 +0200
commit510e4583e056c911adf0be18a559ff02c185d14a (patch)
treec0d9bfb6ce333efe840c64322adf9dad869a425c /gnu/packages/python-check.scm
parent3578fb1323db3f0eadd5749e51095e5f196d78c7 (diff)
gnu: Add python-pytest-parawtf.
* gnu/packages/python-check.scm (python-pytest-parawtf): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 749902271b..486abf1c13 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2439,6 +2440,34 @@ parsed examples as part of your normal test run. Integration is
provided for the main Python test runners.")
(license license:expat)))
+(define-public python-pytest-parawtf
+ (package
+ (name "python-pytest-parawtf")
+ (version "1.0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-parawtf" version))
+ (sha256
+ (base32
+ "08s86hy58lvrd90cnayzydvac4slaflj0ph9yknakcc42anrm023"))))
+ (build-system python-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; https://github.com/flub/pytest-parawtf/issues/1
+ (invoke "pytest" "-k" "not test_mark")))))))
+ (propagated-inputs (list python-pytest))
+ (home-page "https://github.com/flub/pytest-parawtf/")
+ (synopsis "Finally spell paramete?ri[sz]e correctly")
+ (description
+"@code{python-pytest} uses one of four different spellings of
+parametrize. This plugin allows you to use all four.")
+ (license license:expat)))
+
(define-public python-pytest-httpx
(package
(name "python-pytest-httpx")