summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-04-28 00:43:11 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-05-08 12:42:09 +0300
commit3a5c78b287ad80e05d09079abee23cf23b5af471 (patch)
treed6c65c99e5ca79d22b96e1cb9a4ad93cd840e195 /gnu/packages/python-check.scm
parent16e83296d7876a25c86c7a63f53a3181b81ad2dd (diff)
gnu: python-pytest-arraydiff: Update to 0.5.0.
* gnu/packages/python-check.scm (python-pytest-arraydiff): Update to 0.5.0. [native-inputs]: Add python-setuptools-scm. [propagated-inputs]: Remove python-six. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f0211b604b..d3848de95a 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -541,22 +541,22 @@ astropy related packages.")
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")
- (version "0.3")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-arraydiff" version))
(sha256
- (base32 "05bcvhh2ycxa35znl8b3l9vkcmx7vwm5c3fpakbpw46c7vsn4bfy"))))
+ (base32 "1livzfbi7ag17hskd5845dh1kdir24f7jrbw8y2s1pyhzyz4jhbi"))))
(build-system python-build-system)
(arguments
;; Tests require python-astropy, which itself requires this package.
;; Disable tests to avoid the circular dependency problem.
'(#:tests? #f))
(native-inputs
- (list python-pytest)) ; for sanity-check
+ (list python-pytest python-setuptools-scm)) ; for sanity-check
(propagated-inputs
- (list python-numpy python-six))
+ (list python-numpy))
(home-page "https://github.com/astropy/pytest-arraydiff")
(synopsis "Pytest plugin to help with comparing array output from tests")
(description