summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <ldb@leibniz-psychology.org>2023-04-24 12:53:48 +0200
committerLars-Dominik Braun <ldb@leibniz-psychology.org>2023-04-25 11:08:30 +0200
commite619750d0072677df12a4f8eb87e714a6de4e491 (patch)
treec394e679e7df0c74146f741020b30b33f3ef0d72 /gnu/packages/python-check.scm
parent27e1451891db22067f569c60065a7ee1091a6993 (diff)
Revert "gnu: python-pytest-trio: Update to 0.8.0."
Not compatible with python-trio 0.8. This reverts commit 27a4bfbd07022ebabc352a419c7588fcfc881d88.
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm33
1 files changed, 12 insertions, 21 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 9ce093697d..1046602800 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1086,42 +1086,33 @@ simpler.")
(define-public python-pytest-trio
(package
(name "python-pytest-trio")
- (version "0.8.0")
+ (version "0.7.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "pytest-trio" version))
(sha256
- (base32 "0bmmdyjqj5v4a637i4rzm55crv6v3nj268as6x9nr7m76rixnqw3"))))
+ (base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'relax-requirements
- (lambda _
- (substitute* "setup.py"
- (("pytest >= 7.2.0")
- "pytest"))))
(replace 'check
(lambda* (#:key tests? inputs outputs #:allow-other-keys)
(when tests?
- (invoke
- "pytest" "-W" "error" "-ra" "-v" "--pyargs"
- "pytest_trio" "--verbose" "--cov" "-k"
- (string-append
- ;; These tests require network.
- "not test_async_yield_fixture_with_nursery "
- "and not test_try "
- ;; No keyboard interrupt in our build environment.
- "and not test_actual_test "
- ;; These tests fail due to unclean teardown (see:
- ;; https://github.com/python-trio/pytest-trio/issues/122).
- "and not crashed_teardown "
- "and not test_error_collection "))))))))
+ (add-installed-pythonpath inputs outputs)
+ (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
+ "pytest_trio" "--verbose" "--cov" "-k"
+ (string-append
+ ;; Needs network
+ "not test_async_yield_fixture_with_nursery"
+ " and not test_try"
+ ;; No keyboard interrupt in our build environment.
+ " and not test_actual_test"))))))))
(native-inputs
(list python-hypothesis python-pytest python-pytest-cov))
(propagated-inputs
- (list python-async-generator python-outcome python-pytest python-trio))
+ (list python-async-generator python-outcome python-pytest python-trio))
(home-page "https://github.com/python-trio/pytest-trio")
(synopsis "Pytest plugin for trio")
(description