summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-03-10 06:49:48 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-03-11 20:48:01 +0200
commitcfa564bcef30cb0018a63c7c33b62b865b9fc731 (patch)
treeaa3cb0ed4098e09df7b03d5f5b62d2f55b2499fb /gnu/packages/python-check.scm
parentce2637c003be486596fc96d6f7da3c6cc999c163 (diff)
gnu: Add python-testfixtures.
* gnu/packages/python-check.scm (python-testfixtures): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 3eb561c89a..2f449bf0eb 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -29,7 +29,9 @@
(define-module (gnu packages python-check)
#:use-module (gnu packages)
#:use-module (gnu packages check)
+ #:use-module (gnu packages django)
#:use-module (gnu packages openstack)
+ #:use-module (gnu packages python-build)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages web)
@@ -41,6 +43,31 @@
#:use-module (guix download)
#:use-module (guix build-system python))
+(define-public python-testfixtures
+ (package
+ (name "python-testfixtures")
+ (version "6.17.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "testfixtures" version))
+ (sha256
+ (base32 "1nlv2hz20czjp4a811ichl5kwg99rh84l0mw9wq4rk3idzfs1hsy"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; PyTest-Django fails to build in master
+ (native-inputs
+ `(("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ;;("python-pytest-django" ,python-pytest-django)
+ ("python-twine" ,python-twine)
+ ("python-wheel" ,python-wheel)))
+ (synopsis "Tests components for Python")
+ (description "Testfixtures is a collection of helpers and mock objects that
+are useful when writing automated tests in Python.")
+ (home-page "https://testfixtures.readthedocs.io/en/latest/")
+ (license license:expat)))
+
(define-public python-coveralls
(package
(name "python-coveralls")